Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It worked initially (yum install mysql mysql-server), and now it won't.

I removed the working mysql from the repo with yum remove mysql mysql-server and tried to install from rpm source from the mysql website and it failed.

So I removed the rpm install and went to reinstall through yum, and it says the package is unavailable, what do I do? I've tried changing the repo, doing yum update, etc, reverting back my changes, doing yum update again, to no avail.

root@ns5000967 [/home/alex]# yum install mysql mysql-server
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: less.cogeco.net
 * epel: epel.mirror.constant.com
 * extras: centos.bhs.mirrors.ovh.net
 * rpmforge: mirror.rit.edu
 * updates: mirror.agmn.ca
Setting up Install Process
No package mysql available.
No package mysq-server available.
Error: Nothing to do

The most notable things that come up with yum search mysql

MySQL51-client.x86_64 : MySQL - Client
MySQL51-devel.x86_64 : MySQL - Development header files and libraries
MySQL51-server.x86_64 : MySQL - a very fast and reliable SQL database server
MySQL51-shared.x86_64 : MySQL - Shared libraries
MySQL51-test.x86_64 : MySQL - Test suite

Running yum install MySQL51-client MySQL51-server

still failed in my attempts. Right now:

root@ns5000967 [/home/alex]# yum clean all
Loaded plugins: fastestmirror
Cleaning repos: base epel extras rpmforge updates
Cleaning up Everything
Cleaning up list of fastest mirrors

-

root@ns5000967 [/home/alex]# yum list mysql mysql-server
Loaded plugins: fastestmirror
Determining fastest mirrors
epel/metalink                                                                               |  13 kB     00:00
 * base: less.cogeco.net
 * epel: epel.mirror.constant.com
 * extras: centos.bhs.mirrors.ovh.net
 * rpmforge: mirror.rit.edu
 * updates: centos.mirror.gtcomm.net
base                                                                                              | 3.7 kB     00:00
base/primary_db                                                                                   | 4.4 MB     00:00
epel                                                                                              | 4.2 kB     00:00
epel/primary_db                                                                                   | 5.5 MB     00:00
extras                                                                                            | 3.4 kB     00:00
extras/primary_db                                                                                 |  18 kB     00:00
rpmforge                                                                                          | 1.9 kB     00:00
rpmforge/primary_db                                                                               | 2.6 MB     00:08
updates                                                                                           | 3.4 kB     00:00
updates/primary_db                                                                                 | 4.4 MB     00:00
Error: No matching Packages to list

/etc/yum.conf

[main]
exclude=bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*
tolerant=1
errorlevel=1
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=5
bugtracker_url=http://bugs.centos.org/set_project.php?     project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum
distroverpkg=centos-release

-

root@ns5000967 [/home/alex]# ls /etc/yum.repos.d/*
/etc/yum.repos.d/CentOS-Base.repo       /etc/yum.repos.d/CentOS-Media.repo       /etc/yum.repos.d/epel.repo          /etc/yum.repos.d/mirrors-rpmforge             /etc/yum.repos.d/mirrors-rpmforge-testing  /etc/yum.repos.d/rpmforge.repo
/etc/yum.repos.d/CentOS-Debuginfo.repo  /etc/yum.repos.d/CentOS-Vault.repo       /etc/yum.repos.d/epel-testing.repo  /etc/yum.repos.d/mirrors-rpmforge-extras      /etc/yum.repos.d/remi.repo

When I made my repo changes I backed up the repos to a backup directory. When I undid the change, I copied the repos back from backup.

If it could still be a repo depository problem I will follow suggestions in looking into it/checking that they are proper.

Solution:

In /etc/yum.conf it had in it's exclude list mysql. yoonix was able to point this out for me, which I over looked.

 exclude=bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*
share|improve this question
    
OP, I fixed your formatting so it's more legible. –  Aaron Copley Sep 13 '13 at 20:21
1  
you seem misspelled the "mysql-server" package? Can you what "yum search mysql" shows? –  Danila Ladner Sep 13 '13 at 20:22
    
Good catch! Still, it should have found mysql. –  Aaron Copley Sep 13 '13 at 20:25

4 Answers 4

up vote 1 down vote accepted

Look at your yum.conf, specifically the 'excludes' line in the [main] section. It specifically lists 'mysql*'.

exclude: List of packages to exclude from updates or installs. This should be a space separated list. Shell globs using wildcards (eg. * and ?) are allowed.

share|improve this answer
    
Thank you, this fixed the problem! –  LmOtaku Sep 13 '13 at 20:58
    
You stole my answer! I was leading him there! ;) –  Aaron Copley Sep 13 '13 at 21:02
    
Thanks all. In my 12 years using unix/linux, I have never had a package I've installed suddenly go into the exclude list. Usually I leave the repos and yum.conf alone, so in my bewilderment, I never looked much at the yum.conf. But thanks all for taking the time to lead me in the right direction. –  LmOtaku Sep 13 '13 at 21:07

In my case I had used yum remove mysql mysql-server. My VPS is using centos release 6.5.

I simply ran cpanel upcp script:

root@server [~]# /scripts/upcp

It has worked for me.

share|improve this answer
  • Try clearing the the yum cache.
    yum clean all
  • Try listing packages to verify your mirrors are good and see if yum thinks it's still installed.
    yum list mysql mysql-server
share|improve this answer
    
Updated my question with the result to that. –  LmOtaku Sep 13 '13 at 20:34
1  
There's something wrong with your repository configuration. If you've messed with it at all, undo it. Show us /etc/yum.conf and /etc/yum.repos.d/*. –  Aaron Copley Sep 13 '13 at 20:41

Just run

"yum install MySQL51-client.x86_64 " 

and

"yum install MySQL51-server.x86_64"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.