Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

CTRL+A, for example, is printing "^A" instead of returning my cursor to the start of the line.

This happens via ssh, in a screen session, or on the hard console. $TERM shows either xterm or linux depending on which one I'm on.

How do I get the keymap fixed?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You have enabled vi mode for bash somewhere like this "set -o vi" (probably in your ~/.bashrc file)

You need to remove that line or change to "set -o emacs"

share|improve this answer
    
Yes, it went to vi mode. Can't find WHERE it went to vi mode, especially since set alone says nothing about it, but thanks for the fix. –  Jeff Ferland Aug 13 '09 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.