Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been issued an SSL certificate for www.mydomain.com, I have been able to successfully implement the certificate for the site and the site is working is https.

However, I have not been able to install the SSL in the Openfire. I have tried every method.

Also, when I try importing the certificate from the web admin panel, it shows me the following error :

There was an error one importing private key and signed certificate. Error message: org.bouncycastle.jce.provider.JCERSAPrivateCrtKey cannot be cast to java.security.KeyPair 

I have been trying this for days now. I have tried almost every tutorial out there. Any help would be highly appreciated.

share|improve this question
    
By chance are you giving it just the key, instead of the keypair? –  Falcon Momot Sep 15 '13 at 13:15
    
As in?? With the intermediate key as well you mean?? This is what I am doing : In the key field, I am putting the contents of the www_mydomain_com.key and in the Other Field, I am putting the concatinated www_mydomain_key.crt + intermediate.crt –  Sankalp Singha Sep 15 '13 at 13:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.