Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Centos 6 on my new Xen Server (XenServer release 6.2.0-70446c). Everything went smooth. System is working fine but now I want to change boot device on that VM to boot from DVD (iso from nfs storage) But in properties there is only Hard Disk option... I was looking for adding some new DVD device but didn't find where (On Vmware it's very simple and maybe here to but I was searching quite long time and it's became frustrating )... It's strange to me because when I was creating VM for Centos system had to start from DVD and everything went well and without problems but now when I wan't to change boot order I can't (don't know how) enter image description here

What I do wrong ... because I don't believe that it is impossible on Xen. How to accomplish this ?

share|improve this question
up vote 5 down vote accepted

I guess your CentOS 6 instance is running in paravirtualized mode and such behavior is just a side effect of it. To access virtual CD/DVD drive, you need to start the instance in recovery mode. From VM menu, select Start/Shut down and Start in recovery mode. This

share|improve this answer

I had the same issue as B14D3 using the same version of Xenserver and VMs with Centos 6 and 7. I need to resize the file system using gparted, to accomplish that I need to boot from the live dvd.

I can't find the "Start in recovery mode" as referenced on the answer above. I guess it only works with Ubuntu or another OS.

I've found the solution for this problem: Boot a guest VM from CD or DVD in XenServer

Which is basically executing this command in any of the hosts of the pool:

xe vm-param-set HVM-boot-policy="BIOS order" uuid=[uuid of your vm]

You can find the uuid of your vm in the "VM general properties" of each VM. Find the row where it says "UUID"

After running the command you will see the boot options (I tried to include an screen shot but I don't have enough reputation)

I hope it helps.


share|improve this answer
Thanks a lot Philippe, I had this issue with the "Boot Options" not displayed in some VMs (I think the ones I created from a snapshot of a VM), your hint worked perfectly! – Rudolf Mayer Apr 25 at 11:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.