Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On my server I'm running PHP 5.5.1. I would like to install php-gd, but when I'm trying to install it, it always says:

yum install php-gd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.supportex.net
 * epel: mirror.1000mbps.com
 * extras: mirrors.supportex.net
 * updates: mirrors.supportex.net
 * webtatic: uk.repo.webtatic.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-gd.x86_64 0:5.3.3-23.el6_4 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-gd-5.3.3-23.el6_4.x86_64
--> Finished Dependency Resolution
Error: Package: php-gd-5.3.3-23.el6_4.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-23.el6_4
           Installed: php-common-5.5.1-1.el6.remi.x86_64 (@remi-test)
               php-common(x86-64) = 5.5.1-1.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

it seems that the php-gd package is available on the server for php 5.3. I can't delete or removed it from the server. I'll always receive this message: Package(s) php-gd available, but not installed.

Can someone help me with this?

Thanks in advance.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You installed PHP from the remi-test repository. It is disabled by default. You should re-enable this repository if you want to install further PHP packages from it.

share|improve this answer
    
Alright, I enabled it, but now I'm receiving the following error: pastie.org/private/3i0ocu8lqqwfzssrxeui0w. It takes the wrong version, php 5.4 and not for 5.5. –  Kevin Gorjan Sep 16 '13 at 19:36
    
I said remi-test, not remi. –  Michael Hampton Sep 16 '13 at 19:51
    
Sorry, changed it and now everything works fine! Thanks! –  Kevin Gorjan Sep 16 '13 at 20:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.