Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have come across a very weird problem. My cURL PHP extension doesn't seem to be running.

I have installed cURL using this command:

sudo apt-get install curl libcurl3 libcurl3-dev php5-curl

And everything runs fine in the installation process, it restarts apache2 without any errors.

I checked the php.ini file and added a line at the end:

And it still doesn't work.

Thanks in advance!

share|improve this question
What doesn't work? – Michael Hampton Sep 18 '13 at 2:36
It just simply doesn't load up when starting apache. I have tried everything I know of. – Vilsol Sep 18 '13 at 2:37
Which php.ini file did you edit? – EEAA Sep 18 '13 at 2:38
/etc/php5/apache2/php.ini – Vilsol Sep 18 '13 at 2:39
That is the file that gets listed as main one in phpinfo() – Vilsol Sep 18 '13 at 2:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.