Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would like to use rsyncd server to launch a daemon as post-xfer exec command after the synchronization:

The problem is that even if the daemon is correctly launched, rsync is still hanging, and waiting interactively the daemon to be done.

Here is my rsyncd.conf file:

uid = 0
gid = 0
use chroot = yes
hosts allow =
hosts deny =

path = /etc/blah
post-xfer exec = /bin/bash /etc/blah/rollback.sh &

I have also tried forking on the rollback.sh; with same result: command hangs until post-xfer exec is completely done, and I want the daemon to be launched and the rsync command to terminate.

Is this possible to do such a thing, or do I misconfigure my rsync server?

Many thanks for helping!

share|improve this question
daemon command could help here, haven't tested it though. –  sendmoreinfo May 1 at 11:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.