Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After the migration of a high traffic site, from Redhat to Suse, Internet Explorer users (of at least IE 9) have, in some cases, troubles to view the frontpage (error message: "Internet explorer cannot display the page" which points to a 500 server error). In most cases Internet Explorer does display the page correctly, as do all other browsers. I have checked this on around 10 different computers, with different IE versions and different OS's. Browserstack also displays the site correctly for all versions of IE. So far, I have not been able to reproduce the error myself. On the old server this problem didnt exist.

According to the apache access.log, the error is probably related to a redirect which has been specified in the .htaccess file. The access log gives status 302 in case of the error, after that nothing (for the specific ip address). The error log is empty. See complete .htaccess file below.

SSL has been installed for this site and functions well, without any known errors. Strange detail: if a user who receives the error presses F5, the site then loads without problems, even after rebooting or restarting the browser. This points to a caching problem but so far I have not been able to find the reason.

SetEnv APPLICATION_ENV production

Options All -Indexes
Options +FollowSymLinks

RewriteEngine On

RewriteCond %{SERVER_PORT} !^443$               [OR]
RewriteCond %{HTTP_HOST} !www\.domain\.nl     [NC]
RewriteRule ^(.*)$ https://www.domain.nl/$1   [R,L]

RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]

<Files .htaccess>
    order allow,deny
    deny from all
</Files>

Some other details:

Apache/2.2.12 (Linux/SUSE) PHP Version 5.3.17 Zend Engine v2.3.0 mod_ssl/2.2.12

Who can help please? Apologies that the problem is not very well defined, but am afraid thats related to the problem itself.

Thanks in advance

share|improve this question
    
I would look into your SSL settings as well. I don't recall exactly what it was, but I had a similar issues several years ago. Every browser worked fine but IE would say the ever helpful 'cannot display page'. The problem ended up being the SSL configuration. I had tried to lock down the less secure protocols. Good luck. –  yoonix Sep 19 '13 at 23:13

1 Answer 1

up vote 0 down vote accepted

I experienced the same exact behavior, but without SSL. I was not able to determine the source of the problem (other than IE being incompatible with basic HTTP protocol), but this code in htaccess fixed the issue:

BrowserMatch "MSIE [2-8]" nokeepalive downgrade-1.0 force-response-1.0

If that does not help, test that %{HTTP_HOST} actually contains what you expect it to in IE, because apparently HTTP_HOST can be empty.

share|improve this answer
    
This seems to have solved the issue, thanks a lot for helping out! –  Eastwest Software Oct 18 '13 at 9:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.