Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use Sequel Pro as a remote MySQL client. Today I tried to connect to my server with these settings:

enter image description here

I get this error message when I click connect:

enter image description here

I don't understand how only a few days ago when I tried to connect it worked with the same settings.

share|improve this question
    
Is mysql runing and allow conections from remote ips ? ( bind adress ) –  Skamasle Sep 20 '13 at 18:40
    
@Skamasle Yes it is. –  baileyseymour Sep 20 '13 at 18:41
    
Does it say "skip-networking" in your my.cnf? Does DNS resolve correctly? Are there firewall rules on the server? –  Ben Lutgens Sep 20 '13 at 18:55
    
And from local host can you conect ? if yes maybe is a server firewall blocking conections to 3306 port or skip-networking option like say Ben Lutgens –  Skamasle Sep 20 '13 at 19:02

2 Answers 2

You need to ensure that the DB allows remote connections as well. Check the permissions on the users and databases.

This is an example:

GRANT ALL PRIVILEGES ON *.* TO 'root'@'192.168.1.%'
    IDENTIFIED BY PASSWORD 'some_characters'  
    WITH GRANT OPTION;
FLUSH PRIVILEGES;
share|improve this answer

My guess is that MySQL is either stopped, isn't bound to port 3306, or that a firewall is blocking the connection. Do you have shell access to the server? Log in to the server and make sure mysqld is running. Then check whether port 3306 is accepting connections. Then check local and external firewalls to make sure they're allowing inbound 3306.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.