Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm puzzled about this process. Historically when I've setup an LACP bond on a piece of physical hardware I have to create the analogous setup on the switch. How does this work with a virtual machine (Xen, VMWare, whatever)? How would it be handled if one machine wanted to bond several NICs while others didn't?

share|improve this question
    
What are you goals in bonding? There may be other modes you can setup that don't require switch config –  Zypher Sep 20 '13 at 19:13
    
Goal is to provide room for more traffic. –  ethrbunny Oct 10 '13 at 12:02

1 Answer 1

up vote 6 down vote accepted

In general, you don't do the bonding on a virtual machine, you do it on the hypervisor. You then present the bonded interface to the virtual machines as a single interface.

share|improve this answer
    
This is what I did (Xen 6.2). I have a shared storage on a 10Ge network via two bonded NICs. There are 4 other 1Ge NICs available also. I didn't change anything on the switch when I setup the 10G pair and it's working fine. This might be Xen or Equallogic doing some magic but adding this pair to a VM doesn't work. Still trying to debug it. –  ethrbunny Sep 20 '13 at 19:33
    
You do have to set up the switch with a hypervisor the same way you did with a physical server. Otherwise, it should work the same. –  John Sep 20 '13 at 19:34
    
V strange that it's working then. –  ethrbunny Sep 20 '13 at 19:37
    
Which mode did you select when creating the bond? 6.2 offers 4 options, not all of them require switch support. Only the 2 LACP options require switch support. –  fukawi2 Sep 20 '13 at 23:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.