Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am a newbie server manager and trying jails. It's too hard to configure it. So I decided to use ezjail utility. It seems working, but I got an issue.

When I installed my FreeBSD box, it was 9.0-RELEASE. After I upgrade it, it became 9.1-RELEASE-p7.

The problem is ezjail tried to download FreeBSD distro from FreeBSD FTP site. And it failed because ezjail wanted 9.1-RELEASE-p7 and the site has only 9.1-RELEASE.

I tried forcing download by manually specifying 9.1-RELEASE path, but created jail doesn't work with this message.

Configuring jails:.
Starting jails: cannot start jail "example_com":
.
Error: Could not start example.com
  You need to start it by hand.

I have no idea why it doesn't work. What is the recommended way to configure a jail for beginner?

P.S. My test VM is using DHCP and doesn't have static IP and domain name. can it cause this problem?

Update

I succeeded to install a jail using bsdinstall jail $JAIL_NAME. Anyway, I have no idea how it's done...

share|improve this question
    
It's kind of hard to understand what you're trying to accomplish. Maybe add any relevant /var/log messages? You're trying to start a jail and it's failing right? What do the patch issues and version issues have to do with that? –  inetplumber Sep 23 '13 at 0:30
    
@inetplumber As I added on update, I did it using bsdinstall, and now I am not sure which file is really relevant to ezjail. I'm sorry, and I will update this QA as I get better result. –  Eonil Sep 23 '13 at 0:41
    
check out /etc/rc.conf to see if bsdinstall auto made some config examples you can copy and crib for a manual configuration in the future. also forums.freebsd.org is THE go to place for freeBSD related stuff. I would highly recommend it (they can be rough - but it's worth it). –  inetplumber Sep 23 '13 at 1:10
    
"So I couldn't fetch it due to different patch-level version number." <-- You couldn't fetch what?? What program are you trying to fetch something with? The jails are configured in /etc/rc.conf as inetplumber mentioned. Configuring them really isn't hard at all, what were you having problems with exactly?? This really isn't a question so much as a rant about something not working... –  Chris S Sep 23 '13 at 3:01
    
@ChrisS ezjail tries to download FreeBSD distro from FreeBSD FTP site. And it failed because ezjail wanted 9.1-RELEASE-p7 and the site has only 9.1-RELEASE. It was the message I saw. –  Eonil Sep 23 '13 at 3:34
show 1 more comment

1 Answer 1

I switched to qjail, and it's working magically. All I need is only FreeBSD disc. I think difference of patch-level may cause some problem, but currently, I satisfied on qjail.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.