Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My MOTD is showing:

*** /dev/md2 will be checked for errors at next reboot ***
*** /dev/md1 will be checked for errors at next reboot ***
*** /dev/md3 will be checked for errors at next reboot ***

However, a standard sudo shutdown -r now does not appear to check the disks and the message remains.

My guess is that the partitions 'should' be checked and that they are not being... so how can I get Ubuntu to check the partitions at reboot and keep things nice and safe?


Update - this is the output of cat /etc/fstab

proc /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/md/0 none swap sw 0 0
/dev/md/1 /boot ext3 defaults 0 0
/dev/md/2 / ext4 defaults 0 0
/dev/md/3 /home ext4 defaults 0 0

Update 2 - One message gone...

Using @christianwolff's suggestions...

sudo rm /var/lib/update-notifier/fsck-at-reboot 
sudo touch /forcefsck
sudo shutdown -r now

And now the motd is down to

*** /dev/md1 will be checked for errors at next reboot ***
*** /dev/md3 will be checked for errors at next reboot ***

So 'md2(ext4)' has been checked and the message updated.

share|improve this question
add comment

2 Answers

That's a known bug. Your partitions seem to be fine. It's just the MOTD which is "out of date". Just delete the file /var/lib/update-notifier/fsck-at-reboot and it's gone. Had the same issue and this fixed my problem.

Here are some details about it: https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/692355/comments/9

share|improve this answer
    
The fsck-at-reboot file was recreated for me at reboot - so a bit more prodding required. But thanks for the pointer to the bug. –  jamesc Oct 14 '13 at 17:05
    
And I assume the file is still not empty? The file itself exists permanently but should be empty. For ext3/ext4 filesystems you can force a check using touch /forcefsck. Which filesystem type are you using? –  cwo Oct 15 '13 at 5:53
    
In the list above they file systems are a mix of ext3 and ext4 - I've updated the question. –  jamesc Oct 17 '13 at 10:49
    
And yes, the file is still not empty - so it was recreated with the messages. I'll see if I can force a check now. –  jamesc Oct 17 '13 at 10:52
    
At least one filesystem is down! ;-) Have you tried to do a fsck on the other two? I think you can umount /boot and /home while your system is running. You may want to prevent other users to connect while you're checking. The command should be fsck oder fsck.ext3/fsck.ext4. –  cwo Oct 18 '13 at 8:41
add comment
up vote 1 down vote accepted

Thanks to @cwo's suggestions I've been able to clear out the problem. This is a server on Hetzner's system - it's configured in their default Ubuntu way.

Unmount /boot and /home and check them manually...

sudo umount /boot
sudo fsck /boot

It does appear that the file systems weren't being checked at all at reboot time...

/dev/md1 has gone 320 days without being checked, check forced.

Then mount that back again when done.

sudo mount /boot

I repeated the same process for /home, however had to ensure that that no services were running on the filesystem which would prevent the umount.

Once completed and remounted, I cleaned out the message file, marked the system for a file check and rebooted.

sudo rm /var/lib/update-notifier/fsck-at-reboot
sudo touch /forcefsck
sudo shutdown -r now

This brought the system back up with all file systems checked and the MOTD cleaned.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.