Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm attempting to install Oracle-Java6 on my VPS, running ubuntu-10.04 for the purpose of running Openmeetings. I installed the ppa webupd8team/java, updated and ran sudo apt-get install oracle-java6-installer. At the end of the installation, I am presented with the following error message

Creating jdk1.6.0_45/jre/lib/rt.jar Killed ERROR: Failed to unpack JAR file:

jre/lib/rt.jar

Installation failed. Please refer to the Troubleshooting Section of the Installation Instructions on the download page. cannot unpack jdk6 Oracle JDK 6 is NOT installed. dpkg: error processing oracle-java6-installer (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: oracle-java6-installer E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried running sudo apt-get -f install to see if that helps but am presented with the same error.

Any help would be greatly appreciated.

share|improve this question
    
We usually (read: always) install java from the packages available on the oracle website instead of the OS package manager. mkdir /usr/local/jdk-1.6.xxx/ ; tar -xzvf /tmp/jdk-1.6.xxx /usr/local/jdk-1.6.xxx ; tends to be easier and more stable for us. –  lVlint67 Sep 23 '13 at 19:38
    
@lVlint67: & how do you update those packages later, just removing these directories & repeating the process for newer version ? but I what's the issue in installing through webupd8 ppa ? –  user01 Sep 24 '13 at 10:04

1 Answer 1

Much prefer to install JDK using the ff:

Download package on the oracle official repo

http://www.oracle.com/technetwork/java/javasebusiness/downloads

then put the package on your prefer location e.g /opt/java

then change access permission by typing:

sudo chmod 775 jdk-6u45-linux-i586.bin

then extract the package:

sudo ./jdk-6u45-linux-arch.bin

share|improve this answer
    
Thanks for the tip. I actually ended up upgrading my server's operating system to Ubuntu 12.04, then no problem. Thanks for the response though. –  neanderslob Sep 24 '13 at 4:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.