Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have been tasked with trying to reproduce an issue one of our developers is running into. On certain FTP servers, the FTP library he is using (Starksoft/Biko) returns a "530: Not Logged In" error. But, if we connect manually to these servers we get an error saying "Having trouble setting permissions".

I've been trying to see how to setup an FTP server that could reproduce this issue. It happens on multiple FTP servers, but works on lots of others just fine. I am not sure what kind of FTP server is on the other end.

The closest I could come in my reasearch was to maybe somehow disable users from being able to CHMOD files. Am I on the right track? How do I set up an FTP server that does not let users set permissions on files?

UPDATE: The specific error from WinSCP is "Uploaded file blah was successful, but error occurred when setting permissions and/or timestamp". Looking this up on the WinSCP site never really says WHY you get this message, but they have switches to allow you to ignore it. What I need is to be able to set MY server to generate this error in WinSCP

share|improve this question
    
Which FTP-Server do you use? –  Stony Sep 24 '13 at 21:43
    
I am using WU-FTP. BUt I have no idea what they are using on the other end –  SouperGrover Sep 24 '13 at 21:45

1 Answer 1

I think you can configure the file permissions in your configuration.

chmod no anonymous
chmod yes real,guest

So you can disable chmod for specified users. More informations here

share|improve this answer
    
I found that and tried it but no change. I want authenticated users to be blocked as well. Also - see my update above for new information –  SouperGrover Sep 24 '13 at 23:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.