Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting the following in my Puppet master syslog over and over:

Sep 27 11:52:05 puppet1 puppet-master:  Not collecting exported resources without storeconfigs
Sep 27 11:52:06 puppet1 puppet-master:  Not collecting exported resources without storeconfigs
Sep 27 11:52:06 puppet1 puppet-master:  Not collecting exported resources without storeconfigs

I'm not actually using storeconfigs:

[ashinn@puppet1 ~]$ cat /etc/puppet/puppet.conf
[agent]
server                    = puppet.mydomain.com
environment               = production
report                    = true

[main]
logdir                    = /var/log/puppet
vardir                    = /var/lib/puppet
ssldir                    = /var/lib/puppet/ssl
rundir                    = /var/run/puppet
factpath                  = $vardir/lib/facter
pluginsync                = true
certname                  = puppet1.mydomain.com

[master]
modulepath                = $confdir/environments/$environment/modules
manifest                  = $confdir/environments/$environment/manifests/site.pp
templatedir               = $confdir/templates
autosign                  = $confdir/autosign.conf
ssl_client_header         = SSL_CLIENT_S_DN
ssl_client_verify_header  = SSL_CLIENT_VERIFY
report                    = true
reports                   = hipchat

Any way I can suppress these messages? What do they actually come from?

share|improve this question
    
Do you have any exported resources or collectors defined in manifests? (docs.puppetlabs.com/puppet/2.7/reference/lang_exported.html) –  Shane Madden Sep 27 '13 at 19:28
    
I just grepped through my Puppet repository for @@ and there are a handful of exported resources scattered through modules that I use on most nodes. –  Andy Shinn Sep 27 '13 at 20:50

1 Answer 1

What is output of following command?

$ puppet config print | grep storeconfigs

And then check puppet master:

$ puppet master --configprint all | grep store

I assume you can set in puppet.conf:

storeconfigs = false

Or you can setup e.g. puppetDB as a backend storage for your configs and the message should disappear. Have a look at introducing puppetDB

share|improve this answer
    
[ashinn@workerstage2 ~]$ puppet config print | grep storeconfigs async_storeconfigs = false storeconfigs = false storeconfigs_backend = active_record thin_storeconfigs = false –  Andy Shinn Nov 11 '13 at 19:52
    
ok, check the master's setting –  Tombart Nov 11 '13 at 21:30
    
Both same: [ashinn@puppet1 ~]$ puppet config print | grep storeconfigs async_storeconfigs = false storeconfigs = false storeconfigs_backend = active_record thin_storeconfigs = false –  Andy Shinn Nov 11 '13 at 22:44
    
mmnt, have you tried the puppet master --configprint all | grep store? –  Tombart Nov 13 '13 at 12:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.