Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Apologies if this has been asked before and is noobish, but here goes. I have a SOHO, with a server behind a router. I just set up the server with AD, DNS, and DHCP. I set up the DNS forwarders as the google DNS, and set the DNS server as 127.0.0.1 The server is now apart of the domain network and under network sharing and center it shows it is connected to the network but then not connected to the internet (viz the red x over internet connection) even though it actually is (ie I can browse to google.com). The server has a static IP address, but if I set it to dynamic it will connect to the internet. Obviously, I don't want a dynamic IP address for the server so my question is if I have a static IP for the server and when I go to turn off the router DHCP and forward DNS requests to the server am I going to lose internet connectivity, or will the server finally take over for the router? I feel like I'm missing a crucial step in the setup process, any help?

config as follows

router internal IP: 192.168.1.1

Server

IP: 192.168.1.42 (static)

SM: 255.255.255.0

DG: 192.168.1.1

DNS: 127.0.0.1

C:\Users\Administrator>nslookup
Default Server:  localhost
Address:  127.0.0.1

> nslookup cbsserver.cbs.local
Server:  cbsserver.cbs.local
Address:  192.168.1.42

*** cbsserver.cbs.local can't find nslookup: Non-existent domain
nslookup
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Administrator>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 192.168.1.42
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

Tunnel adapter isatap.{9D10A499-9836-4D9E-A5A7-0784C824557F}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

C:\Users\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : CBSSERVER
   Primary Dns Suffix  . . . . . . . : CBS.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : CBS.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE (NDIS
 VBD Client)
   Physical Address. . . . . . . . . : 00-1E-C9-D6-39-9F
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.42(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{9D10A499-9836-4D9E-A5A7-0784C824557F}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Users\Administrator>
share|improve this question
    
You're trying to run nslookup in interactive mode and noninteractive mode at the same time. Run it one way or the other, but not both. Typing nslookup and then Enter puts nslookup into interactive mode so there's no need to prepend your query with the nslookup command. - support.microsoft.com/kb/200525 –  joeqwerty Sep 28 '13 at 19:15
    
Thanks Joe. I took a leap and turned off dns on the router, and my network is OK. now I just need to figure out how to turn off DHCP on my rotuer... –  john Sep 28 '13 at 19:34
    
what is the router? –  Danila Ladner Sep 29 '13 at 1:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.