Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Yesterday we had a hardware failure and brought our exchange server down. The hardware was repaired and the server was brought back up. Windows server 2008 did the disk check upon bootup and everything was recovered.

However, no users can log into their exchange account! This is true with IMAP, Exchange and OWA! All three of them, refused to accept any users. For example when I try to access OWA, I get the following page http://pastie.org/584061

We verified that all the services are up (IMAP, POP, SMTP, IIS etc). We were able to connect to all those services with their respective ports through telnet. What could be the problem?


It looks like the database cannot be mounted, from Exchange management console, when I try to mount the database it gives:

Microsoft Exchange Error Failed to mount database 'Mailbox Database'. Mailbox Database Failed Error: Exchange is unable to mount the database that you specified. Specified database: SERVER\First Storage Group\Mailbox Database; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-528) .


I read online that there is a repair utility, so I tried it. I navigated to my edb file and ran eseutil /p "Mailbox Database.edb". It printed the following output

*Repair completed. Database corruption has been repaired! Note: It is recommended that you immediately perform a full backup of this database. If you restore a backup made before the repair, the database will be rolled back to the state it was in at the time of that backup. Operation completed successfully with 595 (JET_wrnDatabaseRepaired, Database cor ruption has been repaired) after 885.750 seconds.*

However I am still unable to mount!

share|improve this question
    
need a few bits of info, 1) is the exchange server your domain controller too? 2) have the pc's in the domain been rebooted since the server crashed? –  Keith Aug 14 '09 at 14:43
    
Are all your Exchange services started? –  Sam Aug 14 '09 at 14:46
    
Yes all my services are started. Seems like the storage database is corrupted, any way to repair? –  erotsppa Aug 14 '09 at 14:50
    
Dare I ask...do you have a backup? I would try restoring the your last full backup apply the logs to that and seeing if that works. That should take you up to time of failure. –  ITGuy24 Aug 14 '09 at 19:19
    
Did you ever get this back up and running? –  ITGuy24 Feb 24 '10 at 17:27

4 Answers 4

I had an Exchange Server fail once, my guess is you haven't slept very well or at all since it happened. In my case I forked out the $500 or whatever it was to open a technical case with Microsoft. It was worth every peny, I recommend if the fix isn't immediately apparent to hand it over to the experts. I may get voted down for recommending this but I have to say the Exchange Support team was very good.

share|improve this answer
1  
+1 - Unless you really, really understand how the ESE database engine works you're best off having Microsoft help you on this one. It's something you can troubleshoot yourself in a lot of cases, but if you don't have good backups and you do more damage to the database (potentially making it completely unrecoverable) you're going to wish you'd called Microsoft first. You've already done wrong (with no offense intended) by touching the database and transaction logs without making a safety copy first. –  Evan Anderson Aug 15 '09 at 3:15
    
Got to go with this. If the problem isn't obvious and you don't have a backup you can 'just restore' then phone Microsoft support. Unless of course the value of all the mail and stuff in the mailbox is less than the cost of Microsoft's help. –  RobM Aug 31 '09 at 7:22

If you have a recent backup of the mail store, restore from that right away. If not, before you do anything else, find the Exchange Troubleshooting Assistant and install it on your Exchange server. It will diagnose the database and tell you what needs to be done to mount it.

Technical explaination: You ran ESEUTIL /P. ESEUTIL is a low-level database utility that doesn't know about Exchange. The /P option is destructive: It will remove bad pages (that fail CRC) to make the database good. These bad pages, Microsoft points out, could be nothing, empty pages if you're having a good day. Or they could be someone's attachment. Or the root of their mailbox. Oops.

After running this tool, you need to run ISINTEG. This tool is Exchange-aware and will scan your db, fixing its errors and making it consistent. You may need to run this more than once as ISINTEG will not fix all errors in a single pass if there are many errors.

Just run ISINTEG until no more errors are reported.

Then mount your database.

Microsoft does not recommend leaving a repaired database in production. After, you may have to export your mailboxes with Exmerge, delete the old db, recreate empty user mailboxes and then merge the mail back in.

But if you had a recent backup, forget all that and just restore from that. I can't repeat that often enough.

Did I just say restore from backup?

share|improve this answer

Is the transaction log missing? If so, http://technet.microsoft.com/en-us/library/bb267001.aspx.

share|improve this answer
    
how can I tell if the transaction log is missing? –  erotsppa Aug 14 '09 at 15:26
    
In the folder where the Exchange db is, there should be a series of files in the form E<n>.log, starting at E00.log. These must not be deleted. –  dmoisan Aug 16 '09 at 15:00

Certainly the problem lies in database mounting which simply means the recovered database are not in accessible state. You need to opt for advanced and powerful third party edb repair tool and you must not avoid doing this as it’s the matter of your critical business data, get it repaired soon and avoid accessing or using the database for ay purpose as it may increase your trouble.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.