Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of our Amazon EC2 instances can no longer connect to itself using its public DNS . It says "unknown host". Previously, when used from within EC2, the public DNS resolved to the current internal IP. This is still the case for another instance we also use.

This has worked for the previous 8 months. Last week, our continuous integration server on that machine ran into the problem a few times. After the instance was started today, connecting via public DNS no longer works at all, even though the elastic IP is definitively attached to the instance.

Pinging that public DNS entry from elsewhere - both from inside and outside EC2 - works perfectly fine. The instance can ping itself using the elastic IP, but we want to connect directly. The instance can also ping itself using its current internal IP or internal DNS entry, but as that changes on startup, it is not a solution.

As we did not change the machine configuration in any way for the past two months, I am reasonably sure this is a problem on Amazon's end. Can anyone confirm this, has experienced similar issues or a suggestion what to do to fix this?

Note: we only have the "basic" AWS suppport level, so I can't file an issue with Amazon about this. I did post this question on the AWS forums, though.

share|improve this question
    
can you share a traceroute of the public dns from itself? –  Aditya Patawari Sep 30 '13 at 9:44
    
No, I can't. When started on the instance itself, traceroute says ec2-xx-xxx-xxx-xxx.eu-west-1.compute.amazonaws.com: Name or service not known. I guess this is a genuine DNS issue, not a connectivity one. –  Jens Bannmann Sep 30 '13 at 10:27
    
is internet working on your server? –  Abhishek Anand Amralkar Sep 30 '13 at 11:06
    
add google dns 8.8.8.8 and 8.8.4.4 to resolv.conf and see if this helps. –  Abhishek Anand Amralkar Sep 30 '13 at 11:07
    
Thanks, but internet connectivity was fine. It turned out the problem was caused on Amazon's side, see below. –  Jens Bannmann Oct 2 '13 at 15:06

1 Answer 1

up vote 0 down vote accepted

In the forum thread I started, several other users confirmed the issue. Only some of their instances were affected, and only in some availability zones.

On the same day, an Amazon technician posted in the thread. He confirmed that the issue was caused on their end, and wrote that they had fixed it.

The correct approach for similar issues therefore seems to be:

  1. Check that the elastic IP is attached to the instance.
  2. Check DNS resolution from outside EC2.
  3. Check DNS resolution from inside EC2, but from another instance.
  4. Post on the AWS developer forums for EC2. Explain the issue and include the instance ID and the details above.
  5. Wait one or two days.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.