Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

At our church we have a small network. It consists of a Verizon FiOS router, several Open-Mesh OM2P-HS wireless units that relay the signal to various locations around the church. One of these OM2P-HS units has a NetGear GS108 plugged into it. Into this GS108 is plugged two printers (Dell 2355dn and 2150cn) and a Cisco SPA504G phone. There is one other permanently connected workstation in another room and then a number of roaming units (laptops).

On occasion when one goes to print to the printers they show as "offline." Rebooting the printers doesn't fix the problem. Sometimes it is across all computers, sometimes it is on just one computer - right now my laptop can't print but the workstation in the office can.

From my laptop I can ping and visit the web management interface for the printers, but when I have Windows Troubleshooting try to figure out the problem it reports, "Printer is turned off. The printer needs to be turned on in order to print."

I also tried rebooting my laptop, but it still cannot print to the devices and sees them as offline.

Any ideas on why this occurs and how to fix it?

share|improve this question
1  
Both printers go "offline"? Does the Cisco phone go down as well or does it still work? Are the printers installed as local TCP/IP printers? –  TheCleaner Sep 30 '13 at 15:14
    
Both pritners go "offline" on my laptop - but they are not indicating they are offline. Yes, local TCP/IP printers. No, the Cisco phone remains online. –  David Mackey Sep 30 '13 at 15:30
2  
Do you have the ability to physically plug one of the printers directly into the FIOS router instead to test over a few days? You said rebooting the printers doesn't fix it, so what does? Rebooting the GS108 or rebooting the OM2P-HS the switch is on? –  TheCleaner Sep 30 '13 at 15:48
    
I can't plug a printer directly into the FIOS router without significant issues (it is in a separate building). Usually rebooting some combination of the devices work, but this time nothing seems to be working. I start with the printers, then the laptop, then the netgear switch, then the OM2P-HS, then the router. Nothing seems to help. –  David Mackey Sep 30 '13 at 21:32
    
One more idea to help troubleshoot. Can you plug a laptop/computer directly into the GS108 switch the printers are on and then print? If not, can you still ping the printer IP and get to the web mgmt interface? –  TheCleaner Sep 30 '13 at 21:37

3 Answers 3

Even though you can ping the web management page, the actual port the printer is listening on may be blocked or inaccessible.

share|improve this answer
    
That makes sense, but another computer can print to these printers, so that would indicate that the actual printer port is listening, would it not? –  David Mackey Sep 30 '13 at 14:45
1  
Yes, I believe that's narrowing it down to the segment of the network that the other machines are on, as well as the actual clients themselves. –  Noobixide Sep 30 '13 at 15:35
    
All devices are on the same network segment. –  David Mackey Sep 30 '13 at 21:33

Try assigning a static IP to the printer, relaying on DHCP will make the printer IP changes every x time, where x equals the DHCP lease time, so when the windows tries to connect to printer it appears offline to it, some printer drivers can make the windows looks from some dynamic value in the network like a domain which can be mapped to different IP's from time to time.

So upgrading the driver or define the printer in the right way may solve the issue without having a static IP.

share|improve this answer
    
I actually have already given the devices static IPs. This does not seem to resolve the problem. –  David Mackey Sep 30 '13 at 15:31

Assuming other devices are able to print to those printers, then the issue is either your PC or network related. If you can ping, then it most likely is your computer.

My assumption is that you are using Windows 7, but the general troubleshooting can be applied to either Win 8 or XP.

Three possible things you could do:

  1. Verify that the printer IP address is definitely correct on your PC

    a. Click Start

    b. Click Control Panel

    c. Devices and Printers

    d. Right Click on the printer

    e. Select Printer Properties

    f. Make sure under the Ports tab, the correct port is selected

    i. Select Configure to make sure the name of the IP port does in fact point to the correct IP address.

  2. Turn off SNMP Status on the port. As far as Windows is concerned, printer constantly on

    a. Click Start

    b. Click Control Panel

    c. Devices and Printers

    d. Right Click on the printer

    e. Select Printer Properties

    f. Make sure under the Ports tab, the correct port is selected

    g. Click on configure Port...

    h. Uncheck SNMP Status Enabled

  3. Verify you can print ‘offline’. Your printer goes to sleep, your computer cannot connect and thus marks the printers offline.

    a. Click Start

    b. Click Control Panel

    c. Devices and Printers

    d. Right Click on the printer

    e. Click ‘See what’s printing’

    f. Click on Printer (upper left) and remove tick from ‘Use Printer Offline’.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.