Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently bought a VPS and installed LAMP & WordPress. All went ok and then I tried to add the VPS to my domain. My domain is hosted with Yahoo. I added an A record with the IP address of my VPS. But after 1 day I found it is not working. Then I tried to add a custom nameserver. I signed up for namecheap free dns. In free dns I added an A record with my VPS ip address and for CNAME I added the hostname VPS hostname. Namecheap provided me some nameserver and I added it in my domain nameserver section. But it still isn't working. Please help me add my VPS to my domain.

My VPS IP: 162.220.12.177
My Domain Name: shikkharthi.com

share|improve this question

3 Answers 3

You seem to have correctly added the Namecheap nameservers to your domain's record.

Namecheap's DNS servers seem to have a completely empty zone for your domain. This is, of course, a serious problem.

$ host -v -t soa shikkharthi.com freedns3.registrar-servers.com
Trying "shikkharthi.com"
Using domain server:
Name: freedns3.registrar-servers.com
Address: 67.228.228.217#53
Aliases: 

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43410
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;shikkharthi.com.               IN      SOA

Received 33 bytes from 67.228.228.217#53 in 97 ms

I think you should open a support ticket with Namecheap and provide them this information. This is pretty clearly their problem.

share|improve this answer

It seems your A record is not setup correctly.

Here is the dig output for your domain: [root@zee ~]# dig shikkharthi.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> shikkharthi.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37859
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;shikkharthi.com.               IN      A

;; Query time: 244 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Sep 30 19:23:00 2013
;; MSG SIZE  rcvd: 33

If you have setup the A record correctly you should see it mapping with your VPS IP address e.g,

[root@zee ~]# dig google.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31004
;; flags: qr rd ra; QUERY: 1, ANSWER: 11, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;google.com.                    IN      A

;; ANSWER SECTION:
google.com.             300     IN      A       173.194.113.226
google.com.             300     IN      A       173.194.113.233
google.com.             300     IN      A       173.194.113.227

;; Query time: 13 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Sep 30 19:25:05 2013
;; MSG SIZE  rcvd: 204

I hope that helps.

share|improve this answer

I think you try http://freedns.afraid.org/ very easy and very much reliable otherwise you can setup your name server on your VPS also.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.