Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working on configuring a DNS server for a small network. I installed the server, added the DNS role, I configured two forwarders (provided by the ISP) and the clients pick the server up as a DNS server. Everything seems to be working except his own host name (malam1).

This is on a windows client:

C:\Users\Henk>nslookup malam1
Server:  malam1
Address:  192.168.2.1

*** malam1 can't find malam1: Server failed

C:\Users\Henk>nslookup 192.168.2.1
Server:  malam1
Address:  192.168.2.1

Name:    malam1
Address:  192.168.2.1

Linux clients give the error:

[henk@lnxpc1 ~]$ nslookup malam1 
;; Got SERVFAIL reply from 192.168.2.1, trying next server
;; connection timed out; no servers could be reached

I think the windows clients can find the server using netbios, but the Linux clients don't. I can ping the server on its hostname on a windows client, but I get the error message ping: unknown host malam1 on a Linux client.

I did configure a Reverse Lookup Zone with the name 2.168.192.in-addr.arpa. That automatically configured a Pointer (PTR) with the name 192.168.2.1 with data malam1. I also added a Host (A) record there with the name malam1 and as data 192.168.2.1. Nothing seems to work out.

Update

After configuring the servers Primary DNS Suffix, the server malam1 has this configuration:

C:\Users\henk>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : malam1
   Primary Dns Suffix  . . . . . . . : network.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : network.local
                                       Sitecom

A Windows client repots this:

C:\Users\Henk>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : laptop
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Mixed
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : network.local

I tried to do an nslookup for both malam1 and malam1.network.local but none of them seem to resolve to 192.168.2.1:

malam1.network.local

C:\Users\Henk>nslookup
Default Server:  malam1
Address:  192.168.2.1


> set debug
> malam1.network.local
Server:  malam1
Address:  192.168.2.1

------------
Got answer:
    HEADER:
        opcode = QUERY, id = 4, rcode = NXDOMAIN
        header flags:  response, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 0,  additional = 0

    QUESTIONS:
        malam1.network.local.network.local, type = A, class = IN

------------
------------
Got answer:
    HEADER:
        opcode = QUERY, id = 5, rcode = NXDOMAIN
        header flags:  response, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 0,  additional = 0

    QUESTIONS:
        malam1.network.local.network.local, type = AAAA, class = IN

------------
------------
Got answer:
    HEADER:
        opcode = QUERY, id = 6, rcode = NXDOMAIN
        header flags:  response, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
        malam1.network.local, type = A, class = IN
    AUTHORITY RECORDS:
    ->  (root)
        ttl = 900 (15 mins)
        primary name server = a.root-servers.net
        responsible mail addr = nstld.verisign-grs.com
        serial  = 2013093001
        refresh = 1800 (30 mins)
        retry   = 900 (15 mins)
        expire  = 604800 (7 days)
        default TTL = 86400 (1 day)

------------
------------
Got answer:
    HEADER:
        opcode = QUERY, id = 7, rcode = NXDOMAIN
        header flags:  response, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
        malam1.network.local, type = AAAA, class = IN
    AUTHORITY RECORDS:
    ->  (root)
        ttl = 900 (15 mins)
        primary name server = a.root-servers.net
        responsible mail addr = nstld.verisign-grs.com
        serial  = 2013093001
        refresh = 1800 (30 mins)
        retry   = 900 (15 mins)
        expire  = 604800 (7 days)
        default TTL = 86400 (1 day)

------------
*** malam1 can't find malam1.network.local: Non-existent domain

malam1

C:\Users\Henk>nslookup
Default Server:  malam1
Address:  192.168.2.1

> set debug
> malam1
Server:  malam1
Address:  192.168.2.1

------------
Got answer:
    HEADER:
        opcode = QUERY, id = 2, rcode = NXDOMAIN
        header flags:  response, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
        malam1.network.local, type = A, class = IN
    AUTHORITY RECORDS:
    ->  (root)
        ttl = 610 (10 mins 10 secs)
        primary name server = a.root-servers.net
        responsible mail addr = nstld.verisign-grs.com
        serial  = 2013093001
        refresh = 1800 (30 mins)
        retry   = 900 (15 mins)
        expire  = 604800 (7 days)
        default TTL = 86400 (1 day)

------------
------------
Got answer:
    HEADER:
        opcode = QUERY, id = 3, rcode = NXDOMAIN
        header flags:  response, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
        malam1.network.local, type = AAAA, class = IN
    AUTHORITY RECORDS:
    ->  (root)
        ttl = 610 (10 mins 10 secs)
        primary name server = a.root-servers.net
        responsible mail addr = nstld.verisign-grs.com
        serial  = 2013093001
        refresh = 1800 (30 mins)
        retry   = 900 (15 mins)
        expire  = 604800 (7 days)
        default TTL = 86400 (1 day)

------------
*** malam1 can't find malam1: Non-existent domain
>

Why does the nslookup command sill fail?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

This the only server?

Do a verbose/debug query to find out. What about a FQDN lookup, does that work? Do the clients have DNS suffixes to search (since you are doing short name lookup)?

You can debug by doing the following:

  1. run nslookup and hit [enter]
  2. type set debug and hit [enter]
  3. type malam1.mdmarra.local or whatever the FQDN is and hit [enter]

Review the debug output to see what is or isn't resolving properly.

If I had to guess, the clients probably don't have a domain search suffix. But the debug output will tell you what's up.

EDIT: The latest debug log looks like your DNS server doesn't even have an authoritative zone for "network.local". You say you created the reverse zone, is there a forward lookup zone? Is the server running AD or just DNS? Your debug shows that the query for your server is forwarding out to the internet for an answer...which it shouldn't be doing, so it sounds like a forward zone isn't even setup.

share|improve this answer
    
That does seem to be the case, but I don't understand what is going wrong there.. I provided some more information. Can you help me out? –  henk Sep 30 '13 at 18:20
    
1. I don't see a primary dns suffix on the ipconfig output. This should be set under the DNS tab in the advanced TCP/IP settings of the NIC if static, or in DHCP options if using DHCP. 2) the suffix search list should be the full DNS domain, not just "sitecom" unless you create a single-label DNS domain which is a no-no. 3) did the nslookup using the FQDN work fine? –  TheCleaner Sep 30 '13 at 18:44
    
The output is from the server (malam1) but the missing dns suffix seems to be the issue indeed. The server did not have a dns suffix, so it's FQDN was just 'malam1'. I configured it to be malam1.network.local and set the dhcp to transmit that domain name to all the clients. After a server reboot it should be working. The reboot should be happening within an hour, so I'll report here (and mark your answer) as soon as it's rebooted. –  henk Sep 30 '13 at 20:00
    
After the server reboot, the clients have the dns suffix, but the nslookup command still fails.. –  henk Sep 30 '13 at 21:19
    
The debug log looks like your DNS server doesn't even have an authoritative zone for "network.local". You say you created the reverse zone, is there a forward lookup zone? Is the server running AD or just DNS? Your debug shows that the query for your server is forwarding out to the internet for an answer...which it shouldn't be doing, so it sounds like a forward zone isn't even setup. –  TheCleaner Sep 30 '13 at 21:24
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.