Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Currently i'm setting up Centos 6.3 (64 bit) on vm and installing Wordpress: Already adjust /etc/php.ini but seems like overwritten by other settings.

Suspect this is due to selinux feature. My goal is setting up all Wordpress with all feature working like Media files folder creation (permission issue), appropriate max memory and max upload size.

Any suggestion welcome. Thanks.

OS environment snapshot: Linux 2.6.32-279.el6.x86_64 #1 SMP Fri Jun 22 12:19:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux Apache/2.2.15 (Unix)PHP 5.3.3 (cli) (built: Jul 12 2013 20:35:47) Zend Engine v2.3.0 MySQL version: 5.1.61 Source distribution

share|improve this question
    
Can you upload small files? If yes - It's not a selinux. This can be limited on the webserver or php. Please update question with output of following: rpm -Va "httpd*" "mod_*" "php*" (wait for it!), ls -l /etc/php.d –  GioMac Oct 1 '13 at 20:34

1 Answer 1

Check which php.ini is being used. On Command prompt run this command

php -i |grep php.ini

This command will list the currently used php.ini file for system. You can adjust the max_upload limit and other options in this file. After making changes in that file, Restart Apache and you ar done.

share|improve this answer
    
Centos is using /etc/php.ini thats php -i |grep php.ini said. Thought its not on the php.ini itself. Thats why i ask this question. :-) –  Ivan Slaughter Oct 1 '13 at 9:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.