Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am attempting to install OpenTreeMap in a Ubuntu environment. Hosted at DigitalOcean, one of their "Droplets". As part of the install process I have installed and configured Virtual Box and Vagrant to virtualize the environment. I have made it part-way through various apt-get install and each time, I am disconnected from the Virtual box.

[Unpacking libicu48 (from .../libicu48_4.8.1.1-3_i386.deb) ... [/*varies*/]
Connection to 127.0.0.1 closed by remote host.
Connection to 127.0.0.1 closed.

I execute using:

vagrant up
vagrant ssh

Once virtualized, the connection is closed when downloading/installing packages. Not always the same stop point, but it always forces a disconnect. I am still connected to my box via SSH, and when I run vagrant status I show the virtual box as "aborted":

Current VM states:

default                  aborted

The VM is in an aborted state. This means that it was abruptly
stopped without properly closing the session. Run `vagrant up`
to resume this virtual machine. If any problems persist, you may
have to destroy and restart the virtual machine.

UPDATE: Tried the recommendation in the comments, I got further through the process and closer, but it is still forcing a disconnect through normal use of vagrant. This time, at a pip install command.

Any clue as to why this might be occurring?

share|improve this question
    
what if you install packages one by one? –  Danila Ladner Oct 1 '13 at 3:16
    
Why the downvote? Did I not describe my problem accurately? –  Set Sail Media Oct 1 '13 at 14:16
    
@DanilaLadner thank you, I tried one by one and was able to get through part of the install process. Even still, I continue to get disconnected through normal use of vagrant ssh virtualization. –  Set Sail Media Oct 1 '13 at 14:17
    
Is it possible that your server is running out of RAM, and the OOM-killer is killing your VirtualBox process? –  nickgrim Oct 1 '13 at 16:46

1 Answer 1

This sounds like 1 of 2 things:

  1. This part of your post: " I show the virtual box as "aborted":" makes it sound like the VM is kernel panicking and shutting down. If this is the case the VM image could be bad, or incompatible with Virtual box. You may try installing the Virtual box tools before you run updates. (https://forums.virtualbox.org/viewtopic.php?f=24&t=36752)

  2. SSH is timing out...: You could also edit your ssh config (~/.ssh/config on mac/linux) and add the text below. This will try and keep your ssh connection open longer. Your mileage will vary on this depending on your sshd config on the box you're connecting to.

    Host *

    ServerAliveInterval 25

    serveralivecountmax 20

You could also launch something like screen or tmux that would keep your session running. This would rule out SSH timeouts. This may be a bad idea if your updates require you to type Y/N at certain prompts etc...

share|improve this answer
    
Thank you! I will try both of these suggestions. –  Set Sail Media Oct 1 '13 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.