Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Domain Controller - Windows Server 2008 R2 Standard

Client OS - Window Server 2003 ( Terminal Server )

I am unable to ping my Active Directory Domain Name i.e ( Please see the print-screen )

I am successfully able to nslookup & ping my DC server ip address ( Please see the print-screen )enter image description here

I am also attaching print-screen of IP configuration. enter image description here

Can you tell me why i am unable to ping, but successfully able to resolve through nslookup command and also able to ping with DC server ip address

share|improve this question
Does it work if you ping some other server's FQDN (DNS name)? – Alex Oct 1 '13 at 10:32
up vote 3 down vote accepted

You can also use following command to resolve this problem.

1) net stop dnscache

2) net start dnscache

share|improve this answer
I faced with the issue several times on different machines. What is the reason of this behavior? – erop Dec 24 '15 at 14:28

Ping uses the DNS Client service and I think nslookup establishes a winsock connection. Try to stop DNS client service to see if it might help. Make sure you are trying to ping from a client that is joined with the ADC.

Use these commands to reset some of the network states:

As Torai suggested try to flush DNS resolver cache : ipconfig /flushdns
Reset TCP/IP stack to defaults : netsh int ip reset reset.log
Flush routing table : route /f (reboot required)
Reset WINSOCK entries to defaults : netsh winsock reset catalog

I hope that helps.

share|improve this answer

I had an issue like this recently turned out to be the netbios cache was out of date.

Try flushing it using

nbtstat -R

then ping again

share|improve this answer

Please restart Dnscache services. Go to services.msc --> Click on DNS Client and than restart.

share|improve this answer

You probably need to flush your DNS. nslookup is going to the server for it, but local DNS has it cached.

ipconfig /flushdns
share|improve this answer

I had the same problem. I went and turned off firewall and it worked. Usually systems with FireWall enabled do not allow pinging in certain cases. Go to PowerShell. Type in the following.

netsh advfirewall set allprofiles state off

The next line should be generated as


Try pinging your domain name now. Hope this helps! Thanks.

share|improve this answer
OP states that a ping by IP works. – Dave M Sep 7 '15 at 12:40
Also disabling the firewall because you can't ping is a bit of a stretch. – Scott Pack Sep 7 '15 at 14:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.