Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Debian Wheezy installation with Xen in kernel. All is fine but ... when I type a reboot command or shutdown -r now, my server is stuck and I see only that info on screen:

INFO: task reboot:15065 blocked for more than 120 seconds

I tried to change the kernel from wheezy to a kernel from backports - 3.10-0.bpo.2-amd64, but it doesn't help.

Do you have some idea why and what is the problem?

Thank you for help.

Best,

Rafal

share|improve this question
    
You'd probably be better off asking on the Debian Forums. Sounds like some kind of bug. –  Chris S Oct 2 '13 at 13:55
    
Maybe it is. But serverfault i think is good for that too. –  Rafał Kamiński Oct 2 '13 at 14:03
    
What hardware do you have? I had a machine once that hung with messages similar to that...it was the RAID controller. One firmware update later and it's worked fine since. –  Nathan C Oct 2 '13 at 14:26
    
Does anything get written to your logs that is relevant ? –  Iain Oct 2 '13 at 14:37
    
I have Dell PowerEdge r720xd wirh Raid controler. Hmm maybe i have to upgrade firmware raid. I've checked logs and only that i have in dmesg. –  Rafał Kamiński Oct 2 '13 at 15:37
show 1 more comment

1 Answer

The log you provided indicates an I/O problem.

You can start looking at and testing it with vendor provided tools. It can be that this is not a hardware problem, but a Xen problem with insufficient I/O performance.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.