Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Good morning everyone!

Some history, we have mixed environment of Dell Powerconnect 6248 switches and Cisco 3750 switches and a Cisco 6500 core for our Head office.

We have two VLANs 1 & 20 where 20 is used for our VoIP, therefore ports need to be configured to see both VLAN 1 & 20 so there were configured as trunk ports. However, because it is configured as a trunk port, PortFast will not be enabled.

The reason we are trying to trying to enable PortFast because STP is reporting topology changes in seconds! We want to clear up those entries in the logs to help resolve a VoIP issue where calls would intermittently drop.

Any ideas or suggestions will be greatly appreciated!

share|improve this question
    
I've read your question several times and can't figure out what you're actually asking. Is your question "How can I enable portfast on a trunk port"? Do the topology changes occur with portfast enabled or not? What do you mean by "in seconds"? –  David Schwartz Oct 2 '13 at 13:57
    
Hey David, the problem we are trying to resolve is the dropped calls. Thus far, we've been trying to troubleshoot using the logs on the switches but are filled with STP entries about topology changes but there isn't any topology changes at least no new root bridges nor any new bridges. Based on that, we've decided to tackle the STP topology changes first which hopefully help clear up the logs and hopefully streamline STP. –  Richard Oct 2 '13 at 17:19
    
There at this time, I'm really trying to find out how to enable portfast on ports that are configured as trunk ports which will hopefully reduce some of the STP chatter. As for the seconds, according to STP, there is topology change every 30 or so seconds and we can't explain why as no new bridges are being added or removed. Hope that helps clear things up as any ideas, or suggestions would be greatly appreciated. –  Richard Oct 2 '13 at 17:28
add comment

2 Answers

up vote 6 down vote accepted

You should enable portfast on any desktop/phone-port, but only if you have rapid spanning tree configured across your switch network to ensure that loops doesn't kill the network longer than needed.

Regarding trunk (yes, trunk - not truck) ports - On Cisco switches you configure the port to run in access mode, but with a voice vlan added. This is much easier to read than configuring it as a trunk port, setting the allowed trunk vlan etc.

Example:

interface GigabitEthernet1/0/1
 switchport access vlan 1
 switchport mode access
 switchport voice vlan 20
 switchport port-security maximum 2
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 spanning-tree portfast
 spanning-tree bpduguard enable
!

If you have Cisco phones on Cisco switches I recommend that you use the cisco-phone macros instead, as these will auto-configure QoS markings for you.

You'll have to figure out the Dell config on your own..

share|improve this answer
    
Thank you! This looks quite promising! –  Richard Oct 2 '13 at 17:33
    
This did the trick! Thank you! –  Richard Oct 3 '13 at 15:39
add comment

To add portfast to a trunk you need to add the trunk keyword. "spanning-tree portfast trunk"

As pauska wrote, trunking to your phones isn't best practice. Using voice-vlan is better. If you need QoS you can use the macro from cisco. We only do QoS over the WAN and let the routers take care of it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.