Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently experiencing issues with DFS shares and ABE, enabled on a Windows Server 2008 R2 File Server. Everything works fine with Windows, the problem is with Linux/Unix machines.

They aren't able (with the same username) to access the namespace at all: \fileserver\namespace\folder1\subfolder1

I can't access it at all. All I can do is mounting \fileserver\ and see all the available shares: admin$; c$; d$; f$; Namespace

Also from here, I can't access them. Since I manage the Windows Servers and not the unix boxes, I've installed a VM to test it myself, and indeed it doesn't work (Ubuntu 13.04). Even when I use the GUI, it won't work, I'm only able to see the above shares but not access them.

Any help is appreciated.

Thanks

share|improve this question

2 Answers 2

I haven't tried this myself, but it seems to be what you're looking for :

Matt Shay originally posted an identical questions regarding mounting dfs shares in linux (Ubuntu/Linux - Cannot see files in folders when connected to a DFS tree on Windows Server)

He solved his own question and put this guide up on connecting to a dfs within Linux.

I never solved the problem, that is, until I tried again in October 2012. I’m now running Ubuntu 12.04. So, I started all over… I tried a bunch of things from Google… And I finally got it working, even from “Connect to Server” in Nautilus!!!

http://mattslay.com/connecting-ubuntu-to-windows-shares-and-dfs-trees/

share|improve this answer
    
Link only answers are not helpful if the link breaks. Can you add detail from the link to improve this? –  Dave M Oct 7 '13 at 14:50
    
Hi, thanks for your reply. I've been in contact with Unix team in my company and they went back to HP which closed the discussion saying: DFS is not supported with Win Server 2008 R2. Ergo, I got to create a new share outside of the DFS share and everybody was happy again.. Also, Unix didn't even like the Virtual IP assigned to that VM! –  Simone Oct 8 '13 at 15:04

DFS Referrals for domain-integrated namespaces happen via Active Directory and leverage Active Directory Sites and Services topology information to function. DFS Namespaces do not function on Windows computers that aren't joined to the domain, nevermind Linux computers. There may be something in the Samba package to deal with this, but I doubt it. You may be out of luck here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.