Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a multihomed system running Windows 2008 Server Enterprise, and I'm trying to share an Internet connection on a USB wifi adapter with the other networks attached to the system.

To that end, I have installed DHCP, DNS and Routing and Remote Access services. DHCP and DNS are working well, but NAT is the problem.

In this location:

Network Polic and Access Services
   Routing and Remote Access
      IPv4
         NAT

I have added all my internal network interfaces as private interfaces (the wifi adapter didn't show up in the list), and when I try to "New Interface...", to add the USB wifi adapter as a public interface, I just get this dialog box:

---------------------------
Routing and Remote Access
---------------------------
No new router interfaces are available for addition.
---------------------------
OK   
---------------------------

For example, netsh routing ip nat show global outputs this data:

netsh routing ip nat>show interface

NAT Local Wired Configuration
---------------------------
Mode              : Private Interface

NAT Local Wireless Configuration
---------------------------
Mode              : Private Interface

NAT Internal Configuration
---------------------------
Mode              : Private Interface

And netsh routing ip show interface shows this data:

netsh routing ip>show interface
State       Type         Interface
----------  -----------  ---------------------------------------------
Enabled     Dedicated    {6EABF40E-36FA-4AEA-9524-E967F73E0348}
Enabled     Dedicated    Local Wired
Enabled     Dedicated    Local Wireless
Enabled     Internal     Internal
Enabled     Loop Back    Loopback

(I am wondering if the GUID-named adapter is the wifi adapter.)

Here's the output of ipconfig /all for the relevant wifi adapter:

Wireless LAN adapter Inet:

  Connection-specific DNS Suffix  . :
  Description . . . . . . . . . . . : Belkin Wireless G USB Network Adapter #2
  Physical Address. . . . . . . . . : 00-17-3F-8F-76-75
  DHCP Enabled. . . . . . . . . . . : No
  Autoconfiguration Enabled . . . . : Yes
  Link-local IPv6 Address . . . . . : fe80::cd31:4169:aead:c138%13(Preferred)
  IPv4 Address. . . . . . . . . . . : 192.168.100.1(Preferred)
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Default Gateway . . . . . . . . . : 192.168.100.254
  DNS Servers . . . . . . . . . . . : 192.168.100.1
  NetBIOS over Tcpip. . . . . . . . : Enabled

(It's #2 because I unplugged it and re-added it back at some time in the past.)

I'm posting this question from the server and the USB wifi interface is the only way it can get out, so it's certainly working. I just can't figure out how to make NAT know about it.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I've found a way that seems to reliably re-inform NAT of my adapter.

  • Select "Routing and Remote Access" in the server manager
  • Selecting "Disable Routing and Remote Access" in the context (or Action) menu
  • Then "configure and enable..."
  • The wireless adapter is once more visible for selection and configuration with NAT.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.