Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 machines connected to an OpenVPN network but I can't seem to ping or RDP into each other.

EDIT:

Tried adding client-to-client and did a restart of the server and clients, can't ping or access them.

Server.conf:

dev tun
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
reneg-sec 0
ca /etc/openvpn/easy-rsa/2.0/keys/ca.crt
cert /etc/openvpn/easy-rsa/2.0/keys/server.crt
key /etc/openvpn/easy-rsa/2.0/keys/server.key
dh /etc/openvpn/easy-rsa/2.0/keys/dh1024.pem
plugin /etc/openvpn/openvpn-auth-pam.so /etc/pam.d/login
#plugin /usr/share/openvpn/plugin/lib/openvpn-auth-pam.so /etc/pam.d/login #- Comment this line if you are using FreeRADIUS
#plugin /etc/openvpn/radiusplugin.so /etc/openvpn/radiusplugin.cnf #- Uncomment this line if you are using FreeRADIUS
client-cert-not-required
username-as-common-name
server 10.8.0.0 255.255.255.0
push "redirect-gateway def1"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
keepalive 5 30
comp-lzo
persist-key
persist-tun
status 119
4.log
verb 3

NETWORK INFO (LAPTOP):

Ethernet adapter OPENVPN CONNECTION:

   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : CLEANED
   IPv4 Address. . . . . . . . . . . : 10.8.0.6
   Subnet Mask . . . . . . . . . . . : 255.255.255.252
   Default Gateway . . . . . . . . . : 

Wireless LAN adapter Wireless Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : local.domain
   Link-local IPv6 Address . . . . . : CLEANED
   IPv4 Address. . . . . . . . . . . : 10.35.52.167
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . : 10.35.0.1

Tunnel adapter isatap.local.domain:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : local.domain

OTHER MACHINE:

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : CLEANED
   IPv4 Address. . . . . . . . . . . : 10.8.0.10
   Subnet Mask . . . . . . . . . . . : 255.255.255.252
   Default Gateway . . . . . . . . . : 

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : CLEANED
   IPv4 Address. . . . . . . . . . . : 192.168.2.39
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.2.254

The OpenVPN Subnet on the client side is wrong, right?

share|improve this question
    
Check your firewall. Sounds like firewall issue. Try disabling it. –  Frank Thornton Oct 4 '13 at 16:04
    
Worked when I disabled firewall :) –  Jonnhy Oct 4 '13 at 16:05

1 Answer 1

up vote 2 down vote accepted

Try adding client-to-client to your server.conf:

# Uncomment this directive to allow different
# clients to be able to "see" each other.
# By default, clients will only see the server.
# To force clients to only see the server, you
# will also need to appropriately firewall the
# server's TUN/TAP interface.
;client-to-client

http://openvpn.net/index.php/open-source/documentation/howto.html#server

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.