Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to use nginx upload module in my Debian Squeeze server. I already have installed nginx and nginx-extras. the nginx version is 1.4.2. From the package description of nginx-extras, it seems that upload module should be included however nginx -V gives me this list:

nginx version: nginx/1.4.2
TLS SNI support enabled
configure arguments: 
--prefix=/usr/share/nginx 
--conf-path=/etc/nginx/nginx.conf 
--error-log-path=/var/log/nginx/error.log 
--http-client-body-temp-path=/var/lib/nginx/body 
--http-fastcgi-temp-path=/var/lib/nginx/fastcgi 
--http-log-path=/var/log/nginx/access.log 
--http-proxy-temp-path=/var/lib/nginx/proxy 
--http-scgi-temp-path=/var/lib/nginx/scgi 
--http-uwsgi-temp-path=/var/lib/nginx/uwsgi 
--lock-path=/var/lock/nginx.lock 
--pid-path=/var/run/nginx.pid 
--with-pcre-jit 
--with-debug 
--with-file-aio 
--with-http_addition_module 
--with-http_dav_module 
--with-http_flv_module 
--with-http_geoip_module 
--with-http_gzip_static_module 
--with-http_gunzip_module 
--with-http_image_filter_module 
--with-http_mp4_module 
--with-http_perl_module 
--with-http_random_index_module 
--with-http_realip_module 
--with-http_secure_link_module 
--with-http_stub_status_module 
--with-http_ssl_module 
--with-http_sub_module 
--with-http_xslt_module 
--with-ipv6 
--with-mail 
--with-mail_ssl_module 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/headers-more-nginx-module 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-auth-pam 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-cache-purge 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-dav-ext-module 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-development-kit 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-echo 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/ngx-fancyindex 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-push-stream-module 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-lua 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-upload-progress 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-upstream-fair 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-syslog 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/ngx_http_pinba_module 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/ngx_http_substitutions_filter_module 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/ngx_pagespeed 
--add-module=/usr/src/nginx/source/nginx-1.4.2/debian/modules/nginx-x-rid-header 
--with-ld-opt=-lossp-uuid

which does not include upload module. This listing also confirms that upload module should be in squeeze nginx-extras since nginx 1.2.1.

I tried to re-package nginx from source and configure with upload module using this guide, but got error while compiling. I also installed the Wheezy packages by adding repos to /etc/apt/sources.list but they also did not contain upload module.

I hesitate to build nginx from source so I'm really have no other idea and appreciate your hints.

P.S.

 dpkg --list | grep -i nginx
ii  nginx-common                        1.4.2-1~dotdeb.0             small, powerful, scalable web/proxy server - common files
ii  nginx-extras     

               1.4.2-1~dotdeb.0             nginx web/proxy server (extended version)


$dpkg --listfiles nginx-extras
/.
/usr
/usr/lib
/usr/lib/perl5
/usr/lib/perl5/auto
/usr/lib/perl5/auto/nginx
/usr/lib/perl5/auto/nginx/nginx.bs
/usr/lib/perl5/auto/nginx/nginx.so
/usr/lib/perl5/nginx.pm
/usr/sbin
/usr/sbin/nginx
/usr/share
/usr/share/doc
/usr/share/doc/nginx-extras
/usr/share/doc/nginx-extras/copyright
/usr/share/doc/nginx-extras/changelog.gz
/usr/share/doc/nginx-extras/changelog.Debian.gz
/usr/share/doc/nginx-extras/CHANGES.gz
share|improve this question
    
Can you add the output of dpkg --list | grep -i nginx ? –  pkhamre Oct 7 '13 at 7:19
    
just added the package list –  alfish Oct 7 '13 at 7:23
    
Okay, looks like you have the proper package installed. I'm out of ideas, sorry! –  pkhamre Oct 7 '13 at 7:25
    
Can you run dpkg --listfiles nginx-extras and check if there is any upload-module related files? –  pkhamre Oct 7 '13 at 7:26
    
pkhamre, I added the listing. There seems to be no uplod related file there. –  alfish Oct 7 '13 at 7:42
show 1 more comment

1 Answer 1

up vote 1 down vote accepted

Nginx upload module has been removed from Debian package/s, as of this writing. Ref: http://anonscm.debian.org/gitweb/?p=collab-maint/nginx.git;a=blob;f=debian/modules/README.Modules-versions;h=255fceff42ae8ddfd1161d750003f7b58ce92355;hb=HEAD#l37

Whenever you post the output of nginx -V, please consider formatting it. I use

nginx -V 2>&1 | sed 's,--,\n--,g'

to format its output. There are other ways to format too, such as a few mentioned at http://serverfault.com/a/472513/102173 .

share|improve this answer
    
I see. So how can I downgrade nginx to 1.2.1 to be able to use the module? –  alfish Oct 7 '13 at 9:00
    
I always compile Nginx from source and I have never used backports. So, I don't know how to go back. May be you could put it as a separate question in ServerFault. –  Pothi Oct 7 '13 at 9:10
    
BTW, here's my script to compile from source. github.com/pothi/WordPress-Nginx/blob/master/… Please note that it is not tested on Debian 6, but tested with Debian 7! –  Pothi Oct 7 '13 at 9:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.