Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a samba server that is configured to use CUPS printing systems. At the moment 2 printers are defined (via cups's web interface):

root@srv-volta:~# lpstat -v
device for Brother_MFC-9465CDN: dnssd://Brother%20MFC-9465CDN._pdl-datastream._tcp.local/
device for Laserjet-HP-4650: ipp://10.0.0.100/ipp/

but no one is found by samba as shown by:

root@srv-volta:~# smbclient -g -N -L 127.0.0.1|grep -E '^Printer'
Domain=[ISI-VOLTA] OS=[Unix] Server=[Samba 3.6.6]
Domain=[ISI-VOLTA] OS=[Unix] Server=[Samba 3.6.6]

My conf in smb.conf has:

[globals]
   ...
   load printers = yes
   printing = cups
   printcap name = cups
   use client driver = yes

[printers]
   comment = All Printers
   browseable = yes
   guest ok = yes
   path = /var/spool/samba
   printable = yes
   public = yes
   writable = no

OS is debian Wheezy with samba 3.6.6 and CUPS1.5.3. I have many other systems with analogue configuration that work like a charm.

I'd like to understand which debug I can activate to diagnose the problem.

Any help is appreciated sandro *:-)

share|improve this question
1  
I solved the problem thanks to the hint of a collegue: in order to see the printer you also need browseable = yes in the global section. –  Alessandro Dentella Oct 7 '13 at 9:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.