Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got a computer with openvpn server behind the NAT. When I try to connect to it from client - I get this error:

read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)

I've configured forwarding for 1194 port in my router for both TCP and UDP. Here is config file for server:

port 1194

proto udp

dev tun

ca /etc/openvpn/easy-rsa/keys/ca.crt
cert /etc/openvpn/easy-rsa/keys/server.crt
key /etc/openvpn/easy-rsa/keys/server.key  # This file should be kept secret

dh dh2048.pem


ifconfig-pool-persist ipp.txt

keepalive 10 120



status openvpn-status.log

verb 3

And here are my client's configuration:


dev tun

proto udp

remote XXX.XXX.XXX.XXX 1194

resolv-retry infinite



ca ca.crt
cert my-laptop.crt
key my-laptop.key

ns-cert-type server


verb 3

I've tried to follow this Quick Start tutorial but for some reason it didn't help me to start quickly.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Check your certificates - (Use OpenSSL to do this). I've seen this error when trying to use a malformed certificate and/or key.

If your certificates are fine - try switching to TCP and see if that helps.

share|improve this answer
Can't figure out how to check certificates but tried switching to TCP and it didn't help. – Dmitry Mikhaylov Oct 8 '13 at 9:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.