Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a 2008R2 sp1 server, fully patched, that hosts some shares under the directory e:\shares Under that directory I have other shares, such as "Andy" that is shared out for everyone full control, caching set to only files and programs that users specify are allowed offline and ntfs permissions full control.

Connecting from a client workstation (2008R2 terminal server) if I connect a network drive to the share I have found that explorer AND a dos prompt to not always show the updated content of the share. If I have explorer open to the share and create new files in the share they always appear in the explorer window. However if I close the explorer window and then manually create some new files on the server itself in the share location I can then open explorer and the contents of the share appear as it was before the new files were added. As soon as I create a new share, the explorer window then updates (or I can press F5 to update). Weirdly enough I have exactly the same symptoms in a dos prompt - I can do a dir and the contents of the share are stale until explorer is opened.

I can reproduce this issue in another folder under the e:\shares folder (which is not shared out itself, but if i create a new share as e:\andy for example the behaviour does not occur. Access based enumeration should be ruled out as my user account never changes - just pressing F5 or opening an explorer window. In testing I have found that leaving the folder alone, the changes will eventually ripple down to the share view.

Bizarre behaviour - wondering if anyone has some ideas or seen this before?

share|improve this question

1 Answer 1

http://thecitrixman.com/2013/02/11/scanned-files-not-showing-up-in-network-drives had the answer on disabling caching on the terminal server by setting the following. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters] “DirectoryCacheLifetime”=dword:00000000

This fixed the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.