Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a website set up on a hired server. I have full access to this server and I have set up everything that is needed for the website to work, including the mail server. I also want to add that I am not a linux guy and not even close to a system admin.

When my system (mail.dappwall.com) sends an email it is not arriving in a gmail mailbox. I checked mail.log and it says

stats=bounced (..some text) Our system has detected that this 550-5.7.1 message does not meet IPv6 sending guidelines regarding PTR records 550-5.7.1 and authentication.

At http://www.digwebinterface.com/ I provided the IP address of the domain (46.4.88.247) and clicked Dig. The result:

247.88.4.46.in-addr.arpa. 21600 IN  PTR static.247.88.4.46.clients.your-server.de.

This should be okay, right?

Then I tried this:

    dig 247.88.4.46.in-addr.arpa

; <<>> DiG 9.8.1-P1 <<>> 247.88.4.46.in-addr.arpa
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7842
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;247.88.4.46.in-addr.arpa.    IN    A

;; AUTHORITY SECTION:
88.4.46.in-addr.arpa.    86106    IN    SOA    ns1.your-server.de. postmaster.your-server.de. 2013092900 86400 1800 3600000 86400

;; Query time: 2 msec
;; SERVER: 213.133.100.100#53(213.133.100.100)
;; WHEN: Mon Oct  7 21:03:48 2013
;; MSG SIZE  rcvd: 107

I don't know what this means and I don't know what could I do now.

In postfix main.cf I filled out the line below because when it was empty by default, not every mail arrived in gmail mailboxes (status=bounced, mail for mail.dappwall.com loops back to myself).

mydestination = mail.dappwall.com, localhost.dappwall.com, localhost

But now I have this IPv4 error of gmail.

I have access to certain information of the server. I have found that

1. Nameserver: ns1.something-ns.de (I changed 'something'). There are two more nameservers and I can also add some.

I guess something is wrong in the result of the dig command with this:

ns1.your-server.de. postmaster.your-server.de. I haven't changed anyhing in this so it should be something else instead of your-server, right? And also in the result of http://www.digwebinterface.com/ I don't like this 'static.876.54.3.21.clients.your-server.de.' (I haven't changed this either).

I am using postfix for sending emails.

EDIT After adding 88.4.46.in-addr.arpa to the reverse DNS entry at https://robot.your-server.de/server suggested by the problem still stays.

Mail.log without masking anything:

Oct  7 23:22:05 www postfix/pickup[22424]: 98C0F2C41544: uid=33 from=<www-data>
Oct  7 23:22:05 www postfix/cleanup[22434]: 98C0F2C41544: message-id=<20131007212205.98C0F2C41544@Ubuntu-1204-precise-64-minimal.localdomain>
Oct  7 23:22:05 www postfix/qmgr[22425]: 98C0F2C41544: from=<www-data@mail.dappwall.com>, size=3438, nrcpt=1 (queue active)
Oct  7 23:22:06 www postfix/smtp[22443]: 98C0F2C41544: to=<dappwall4@gmail.com>, relay=gmail-smtp-in.l.google.com[2a00:1450:4001:c02::1b]:25, delay=0.58, delays=0.16/0.1/0.17/0.15, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[2a00:1450:4001:c02::1b] said: 550-5.7.1 [2a01:4f8:140:71ed::2      16] Our system has detected that this 550-5.7.1 message does not meet IPv6 sending guidelines regarding PTR records 550-5.7.1 and authentication. Please review 550-5.7.1 https://support.google.com/mail/?p=ipv6_authentication_error for more 550 5.7.1 information. 7si24941299eeo.229 - gsmtp (in reply to end of DATA command))
Oct  7 23:22:06 www postfix/cleanup[22434]: 2312F2C4155C: message-id=<20131007212206.2312F2C4155C@Ubuntu-1204-precise-64-minimal.localdomain>
Oct  7 23:22:06 www postfix/bounce[22445]: 98C0F2C41544: sender non-delivery notification: 2312F2C4155C
Oct  7 23:22:06 www postfix/qmgr[22425]: 2312F2C4155C: from=<>, size=6231, nrcpt=1 (queue active)
Oct  7 23:22:06 www postfix/qmgr[22425]: 98C0F2C41544: removed
Oct  7 23:22:06 www postfix/local[22438]: 2312F2C4155C: to=<www-data@mail.dappwall.com>, relay=local, delay=0.1, delays=0.05/0/0/0.05, dsn=2.0.0, status=sent (delivered to mailbox)
Oct  7 23:22:06 www postfix/qmgr[22425]: 2312F2C4155C: removed
Oct  7 23:24:01 www postfix/pickup[22424]: C05F32C41544: uid=0 from=<root>
Oct  7 23:24:01 www postfix/cleanup[22455]: C05F32C41544: message-id=<20131007212401.C05F32C41544@Ubuntu-1204-precise-64-minimal.localdomain>
Oct  7 23:24:01 www postfix/qmgr[22425]: C05F32C41544: from=<root@mail.dappwall.com>, size=766, nrcpt=1 (queue active)
Oct  7 23:24:01 www postfix/local[22459]: C05F32C41544: to=<root@mail.dappwall.com>, orig_to=<root>, relay=local, delay=0.2, delays=0.13/0.01/0/0.06, dsn=2.0.0, status=sent (delivered to mailbox)
Oct  7 23:24:01 www postfix/qmgr[22425]: C05F32C41544: removed

EDIT 2:

Oct  8 21:42:12 www postfix/pickup[31192]: B32672C414E4: uid=33 from=<www-data>
Oct  8 21:42:12 www postfix/cleanup[31198]: B32672C414E4: message-id=<20131008194212.B32672C414E4@Ubuntu-1204-precise-64-minimal.localdomain>
Oct  8 21:42:12 www postfix/qmgr[22425]: B32672C414E4: from=<www-data@mail.dappwall.com>, size=3425, nrcpt=1 (queue active)
Oct  8 21:42:13 www postfix/smtp[31254]: B32672C414E4: to=<dappwall@gmail.com>, relay=gmail-smtp-in.l.google.com[2a00:1450:4001:c02::1a]:25, delay=0.99, delays=0.15/0/0.22/0.62, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[2a00:1450:4001:c02::1a] said: 550-5.7.1 [2a01:4f8:140:71ed::2      16] Our system has detected that this 550-5.7.1 message does not meet IPv6 sending guidelines regarding PTR records 550-5.7.1 and authentication. Please review 550-5.7.1 https://support.google.com/mail/?p=ipv6_authentication_error for more 550 5.7.1 information. z8si29131291eee.203 - gsmtp (in reply to end of DATA command))
Oct  8 21:42:13 www postfix/cleanup[31198]: A937F2C4155F: message-id=<20131008194213.A937F2C4155F@Ubuntu-1204-precise-64-minimal.localdomain>
Oct  8 21:42:13 www postfix/bounce[31276]: B32672C414E4: sender non-delivery notification: A937F2C4155F
Oct  8 21:42:13 www postfix/qmgr[22425]: A937F2C4155F: from=<>, size=6218, nrcpt=1 (queue active)
Oct  8 21:42:13 www postfix/qmgr[22425]: B32672C414E4: removed
Oct  8 21:42:13 www postfix/local[31271]: A937F2C4155F: to=<www-data@mail.dappwall.com>, relay=local, delay=0.09, delays=0.06/0/0/0.03, dsn=2.0.0, status=sent (delivered to mailbox)
Oct  8 21:42:13 www postfix/qmgr[22425]: A937F2C4155F: removed
Oct  8 21:44:01 www postfix/pickup[31192]: 668DD2C414E4: uid=0 from=<root>
Oct  8 21:44:01 www postfix/cleanup[31282]: 668DD2C414E4: message-id=<20131008194401.668DD2C414E4@Ubuntu-1204-precise-64-minimal.localdomain>
Oct  8 21:44:01 www postfix/qmgr[22425]: 668DD2C414E4: from=<root@mail.dappwall.com>, size=766, nrcpt=1 (queue active)
Oct  8 21:44:01 www postfix/local[31286]: 668DD2C414E4: to=<root@mail.dappwall.com>, orig_to=<root>, relay=local, delay=0.21, delays=0.16/0.01/0/0.05, dsn=2.0.0, status=sent (delivered to mailbox)
Oct  8 21:44:01 www postfix/qmgr[22425]: 668DD2C414E4: removed

enter image description here

Postfix main.cf:

myorigin = /etc/mailname
smtpd_banner = $myhostname ESMTP $mail_name
biff = no
append_dot_mydomain = no
readme_directory = no
mydomain = mail.dappwall.com
mydestination = $mydomain localhost.$mydomain localhost $mydomain
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mynetworks_style = host
mailbox_size_limit = 0
virtual_mailbox_limit = 0
recipient_delimiter = +
inet_interfaces = all
message_size_limit = 0

# SMTP Authentication (SASL)

smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =

# Encrypted transfer (SSL/TLS)

smtp_use_tls = yes
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/ssl/private/mail.dappwall.com.crt
smtpd_tls_key_file = /etc/ssl/private/mail.dappwall.com.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# Basic SPAM prevention

smtpd_helo_required = yes
smtpd_delay_reject = yes
disable_vrfy_command = yes
smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks, permit
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination

# Force incoming mail to go through Amavis

content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings

# Virtual user mappings

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
virtual_mailbox_base = /var/spool/mail/virtual
virtual_mailbox_maps = mysql:/etc/postfix/maps/user.cf
virtual_uid_maps = static:5000
virtual_gid_maps =  static:5000
virtual_alias_maps = mysql:/etc/postfix/maps/alias.cf
virtual_mailbox_domains = mysql:/etc/postfix/maps/domain.cf

DNS entries section in the robot:

@                        IN NS      robotns3.second-ns.com.
@                        IN NS      robotns2.second-ns.de.
@                        IN NS      ns1.first-ns.de.

@                        IN A       46.4.88.247
localhost                IN A       127.0.0.1
mail                     IN A       46.4.88.247
www                      IN A       46.4.88.247
ftp                      IN CNAME   www
imap                     IN CNAME   www
loopback                 IN CNAME   localhost
pop                      IN CNAME   www
relay                    IN CNAME   www
smtp                     IN CNAME   www
@                        IN MX 10   mail
share|improve this question
3  
That error message is clearly about IPv6 but you only talk about IPv4 records. Does your server send mails via IPv6? Does your IPv6 address have a reverse record? –  faker Oct 7 '13 at 20:21
    
I don't think so. How can I check it? Btw I checked the domain (dappwall.com) at ip6.nl at it says it's not ipv6 ready yet. ip6.nl says it's not ipv6 enabled. Please help. –  erdomester Oct 7 '13 at 21:37
    
The logfile you edited into your question shows that you use IPv6 to send e-mails go gmail. The bounce message also includes the following link: support.google.com/mail/answer/… - which explains exactly what is happening –  faker Oct 7 '13 at 22:17
    
Do you mean this? The sending domain should pass either SPF check or DKIM check. –  erdomester Oct 9 '13 at 17:21

1 Answer 1

The log is complaining about your IPv6 address, not your IPv4. Regardless of that it seems as if the destination mail server (gmail) is complaining that your forward and reverse DNS lookups do not match if I'm not mistaken.

mail.mydomain.com should resolve to an IP, and that IP should resolve back to mail.mydomain.com (mail.mydomain.com being whatever domain you configured your mailserver to use to identify itself when sending mails).

You can have your server hoster set up the reverse DNS entries for your IPs. Or if the clients.your-server.de is valid and wasn't changed you can do it yourself by logging into https://robot.your-server.de/server going to "servers", choose the server you want to edit, and enter the reverse DNS name next to the IPs (for IPv4 and IPv6).

Edit: Example added

Example of how forward and reverse lookups should fit together (IPv4 and IPv6) :

# host us1.dopefish.de
us1.dopefish.de has address 192.249.58.230
us1.dopefish.de has IPv6 address 2604:180::ef4b:4638

# host 192.249.58.230
230.58.249.192.in-addr.arpa domain name pointer us1.dopefish.de.

# host 2604:180::ef4b:4638
8.3.6.4.b.4.f.e.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.1.0.4.0.6.2.ip6.arpa domain name pointer us1.dopefish.de.
share|improve this answer
    
I added 54.3.21.in-addr.arpa to the reverse DNS entry. Two mails arrived, the third was bounced with the above error :S And this has been repeated 3 times since. The third msg throws this bounce error then I get status=sent (delivered to mailbox) then this msg again but with different data. The From is changed from www-data@mail.mydomain.com to root@mail.mydomain.com and the To is changed from something@gmail.com to root@mail.mydomain.com, so it's successfully delivering the message to itself instead of the given mailbox. –  erdomester Oct 7 '13 at 21:00
    
I provided all info I have without masking almost anything. –  erdomester Oct 7 '13 at 21:34
    
my bad, seems I didn't explain the reverse dns entry good enough. change your IPv4 reverse DNS entry to "mail.dappwall.com". The IPv6 entry is a little bit more complicated to change. A little bit farther down on the page there is "Subnets:" and it should have an entry "2a01:4f8:140:71ed:: / 64" with a small '+' sign to the left of it. Click on the '+' and then on 'Add new Reverse DNS entry'. In the left box enter '2a01:4f8:140:71ed::2' and in the right box enter 'mail.dappwall.com'. It might take DNS a few minutes to pick up the changes, but that should get forward and reverse DNS happy :-) –  RSchulze Oct 8 '13 at 2:46
    
It still bounces at the third mail. Then I wait a few minutes, send three emails one after the other, 2 arrives fine, the third bounces. I added the log and an image of the DNS settings –  erdomester Oct 8 '13 at 19:44
1  
When did you add the reverse DNS record for the IPv6 address? It may be that (some) servers cached the negative response. If this is causing you problems it might make sense to disable IPv6 delivery for a day or two (inet_protocols = ipv4) and then try again. –  faker Oct 9 '13 at 18:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.