Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having trouble setting up a new server (hosted at "hetzner") with latest XenServer 6.2. IPv4 is working fine, but I'm stuck at IPv6 Setup. What I got so far:

xen:

 $> ip -6 addr
 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436
     inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
 3: xenbr0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500
     inet6 2a01:4f8:xxx:yyyy::2/112 scope global
        valid_lft forever preferred_lft forever
 $> ip -6 route
 unreachable ::/96 dev lo  metric 1024  error -101 mtu 16436 advmss 16376 hoplimit 0
 unreachable ::ffff:0.0.0.0/96 dev lo  metric 1024  error -101 mtu 16436 advmss 16376 hoplimit 0
  [...]
 2a01:4f8:xxx:yyy::/112 dev xenbr0  proto kernel  metric 256  mtu 1500 advmss 1440 hoplimit 0
 unreachable 3ffe:ffff::/32 dev lo  metric 1024  error -101 mtu 16436 advmss 16376 hoplimit 0
 fe80::1 dev xenbr0  metric 1024  mtu 1500 advmss 1440 hoplimit 0
 fe80::/64 dev xenbr0  proto kernel  metric 256  mtu 1500 advmss 1440 hoplimit 0
 ff00::/8 dev xenbr0  metric 256  mtu 1500 advmss 1440 hoplimit 0
 default via fe80::1 dev xenbr0  metric 1024  mtu 1500 advmss 1440 hoplimit 0

 $> ping6 google.de
 64 bytes from fra07s29-in-x17.1e100.net: icmp_seq=0 ttl=56 time=9.68 ms

also: firewall disabled.

VM (CentOS6):

 $> ip -6 addr
 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436
     inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
     inet6 2a01:4f8:xxx:yyy::3/64 scope global
        valid_lft forever preferred_lft forever
 $> ip -6 route
 unreachable ::/96 dev lo  metric 1024  error -101 mtu 16436 advmss 16376 hoplimit 4294967295
 unreachable ::ffff:0.0.0.0/96 dev lo  metric 1024  error -101 mtu 16436 advmss 16376 hoplimit 4294967295
 [...]
 default via 2a01:4f8:xxx:yyyy::2 dev eth0  metric 1024  mtu 1500 advmss 1440 hoplimit 4294967295

 $> ping6 google.de
 From 2a01:4f8:xxx:yyyy::2 icmp_seq=10 Destination unreachable: Address unreachable
 $> ping 2a01:4f8:xxx:yyy::2
 64 bytes from 2a01:4f8:xxx:yyyy::2: icmp_seq=1 ttl=64 time=1.15 ms

Firewall also disabled on this guest.

I followed the howto at http://wiki.hetzner.de/index.php/Citrix_XenServer/en#IPv6 and did all the mentioned steps and tried with different guests. My assigned IPv6-subnet is 2a01:4f8:xxx:yyyy::/64 and my IPv6-Gateway is fe80::1

Any help and further tips for diagnosis is appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It seems I just found the solution myself:

Though the ISPs wiki tells me to add the first IPv6 as default gateway, setting it to fe80::1 works fine.

I deleted the default route and added a new one like this:

 ip route add default via fe80::1 dev eth0

Connection works both ways - incoming and outgoing ipv6.

This is now my guest configuration of /etc/sysconfig/network-scripts/ifcfg-eth0:

 IPV6INIT="yes"
 IPV6_DEFAULTGW="fe80::1"
 IPV6_DEFAULTDEV=eth0
 IPV6ADDR="2a01:4f8:xxx:yyyy::3/64"

I have not much knowledge of IPv6 yet, so I don't know what exactly happened here and if it is the right solution, but it works.

share|improve this answer
2  
Keep in mind that Hetzner's network setup is very non-standard. Don't try to apply this knowledge elsewhere. –  Michael Hampton Oct 8 '13 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.