Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using centos6.4 and i am trying to install nagios on that system, i follow these steps:

1) Download and install repo

http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm

2) Start installation

After installation i found some error:

Error: Package: nagios-3.5.1-1.el6.x86_64 (epel)
           Requires: php
Error: Package: nagios-3.5.1-1.el6.x86_64 (epel)
           Requires: httpd
Error: Package: nagios-plugins-mysql-1.4.16-5.el6.x86_64 (epel)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
Error: Package: nagios-plugins-mysql-1.4.16-5.el6.x86_64 (epel)
           Requires: libmysqlclient.so.16()(64bit)

I have check httpd and installed php. They're both working fine but I'm still unable to start nagios.

share|improve this question

closed as off-topic by Jenny D, mdpc, Nathan C, Falcon Momot, Ward Oct 10 '13 at 2:48

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Jenny D, Nathan C, Ward
If this question can be reworded to fit the rules in the help center, please edit the question.

    
How have you checked/installed these dependencies? –  Drew Khoury Oct 9 '13 at 11:09
    
i apply command #httpd status and result was showing status of apache. –  dhakad Oct 9 '13 at 11:31
    
and if i am trying to install it by yum command: yum install php/httpd showing result:root@supernova [~]# yum install php Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile * epel: fedora-epel.mirror.lstn.net Setting up Install Process No package php available. Error: Nothing to do </pre> same with httpd –  dhakad Oct 9 '13 at 11:34

1 Answer 1

up vote 1 down vote accepted

Verify that php and http are installed

yum list | grep php
yum list | grep http

Verify that you have the necessary repos active

yum repolist

repo id                  repo name              status
centos6-x86_64           CentOS 6               13,152
centos6-x86_64-updates   CentOS 6 Updates       5,771
epel6-centos6-x86_64     EPEL 6 for CentOS 6    278

Very the package you want to install

yum search php
yum search http

Install the necessary packages

From a quick look at your comments I don't think you have all the necessary repos enabled. It looked like you were only looking at epel. If this is the case then it could be why you are not finding php and httpd.

share|improve this answer
    
Just a small tip, but yum list php httpd will be much faster. –  Aaron Copley Oct 9 '13 at 19:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.