Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

For starts I looked everywhere online for this, a lot of people have the problem, no one has a working solution.

I've installed mongodb using yum and their instructions provided at http://docs.mongodb.org/manual/tutorial/install-mongodb-on-red-hat-centos-or-fedora-linux but I repeatedly get the same errors. I even tried mongod --repair but it's not different from the error below.

Wed Oct  9 08:42:22.905 [initandlisten] MongoDB starting : pid=20799 port=27017 dbpath=/data/db/ 64-bit host=fluffyspikes.com
Wed Oct  9 08:42:33.359 Invalid access at address: 0x37afc6d520 from thread: initandlisten

Wed Oct  9 08:42:33.359 Got signal: 7 (Bus error).

Wed Oct  9 08:42:33.362 Backtrace:
0xdddd81 0x6d0d29 0x6d12b2 0x37ad00f500 0x37afc6d520 0xde50d1 0x6d6a70 0x6d74ed 0x6ddfd0 0x6dfc29 0x37ac41ecdd 0x6cf999
 mongod(_ZN5mongo15printStackTraceERSo+0x21) [0xdddd81]
 mongod(_ZN5mongo10abruptQuitEi+0x399) [0x6d0d29]
 mongod(_ZN5mongo24abruptQuitWithAddrSignalEiP7siginfoPv+0x262) [0x6d12b2]
 /lib64/libpthread.so.0() [0x37ad00f500]
 /usr/lib64/libstdc++.so.6(_ZNSt13basic_fstreamIcSt11char_traitsIcEEC1EPKcSt13_Ios_Openmode+0) [0x37afc6d520]
 mongod(_ZN5mongo13show_warningsEv+0x4b1) [0xde50d1]
 mongod(_ZN5mongo14_initAndListenEi+0x1a0) [0x6d6a70]
 mongod(_ZN5mongo13initAndListenEi+0x1d) [0x6d74ed]
 mongod() [0x6ddfd0]
 mongod(main+0x9) [0x6dfc29]
 /lib64/libc.so.6(__libc_start_main+0xfd) [0x37ac41ecdd]
 mongod() [0x6cf999]

I don't know whether it's a port issue, but I've tried it with firewall on and port 27017 open and also firewall off.

// Edit Here's my specs:

Physical Remote Dedicated Server Mongo installed via yum from the 10-gen repo

//uname -a
Linux xxxxxxx.com 2.6.32-358.18.1.el6.x86_64 #1 SMP Wed Aug 28 17:19:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

//mongod --version
db version v2.4.6

//init command
mongod

//ls -l /data
total 4
drwxr-xr-x 2 mongodb mongod 4096 Oct  7 09:12 db

not really sure where the mongodb user comes in whether I'm supposed to manually create him, anyways I tried adduser mongodb and giving it chown rights, but still same results.

Anyways I didn't touch the conf, here's the top important portion:

# mongo.conf

#where to log
logpath=/var/log/mongo/mongod.log

logappend=true

# fork and run in background
fork = true

port = 27017

dbpath=/data/db

# location of pidfile
pidfilepath = /var/run/mongodb/mongod.pid

# Disables write-ahead journaling
# nojournal = true
share|improve this question
    
"Got signal: 7 (Bus error)." is the key. Essentially, this is an invalid memory access. I'd be inclined to think that this is most likely a hardware error in this case, as it's happening during initialisation and from info provided, I take it that you haven't got existing databases. As it's a physical machine and not virtualised, I'd recommend you check your syslog for memory or disk errors, and perhaps run a memory checker and smartctl to get a better view also. –  Ruairi Oct 17 '13 at 9:00
    
Thank you I'll run a test. The only issue I can think of is, I have meteorjs installed which installs it's own instance of mongodb but it uses a different port, that works fine. Second don't know if this means anything but I have gotten other similar services like redis up and running after this error. –  Marius Miliunas Oct 17 '13 at 12:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.