Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I run the command:

pdsh -w host1,host2 tail -f /var/log/apache.log

I get the following error:

pdsh@myhost: host2: rcmd: socket: Permission denied
pdsh@myhost: host1: rcmd: socket: Permission denied

Any ideas?

share|improve this question

Found the answer. rcmd_default needs an entry:

echo "ssh" > /etc/pdsh/rcmd_default

share|improve this answer
    
Don't know why this was downvoted. It solves the issue for me. If it didn't work for the downvoter then they should have made a comment. – Brendan Maguire Dec 9 '13 at 13:55
    
Agreed. This also worked for me. – simao Feb 5 '14 at 13:28
    
Worked for me too. (Well, I needed to create and hand-edit rcmd_default because I got permission denied even with sudo echo ..., but same diff.) Thanks. – Josh O'Brien Feb 12 at 18:33

You can use PDSH_RCMD_TYPE=ssh like:

PDSH_RCMD_TYPE=ssh pdsh -w host1,host2 tail -f /var/log/apache.log

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.