Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the problem that my machine turned the root filesystem into readonly mode and remounting it as writeable won't work:

# mount -o remount,rw /dev/sda1 /
mount: block device /dev/sda1 is write-protected, mounting read-only

I want to copy some data away from that system and I attached a USB drive and tried to mount it:

# mount -t ext3 /dev/sdb1 /mnt
mount: /dev/sdb1 already mounted or /mnt busy

/mnt is an empty directory, so mounting there should usually work, but it seems that having this directory on a readonly filesystem doesn't make it possible to mount something there.

I think there is no activity going on for /mnt, since the following command doesn't return any output:

# lsof | grep "/mnt" | grep -v grep

There is no other partition mounted as the readonly root filesystem at the moment. Is it possible to still get the attached disk into the directory hierarchy somehow?

share|improve this question
    
Is there anything useful in your logs regarding the fact that your root filesystem was remounted read-only? –  dawud Oct 10 '13 at 11:16
add comment

4 Answers 4

up vote 3 down vote accepted

The first error message is telling me that you'll need to reboot - there's something wrong with the disk device itself that the kernel can't resolve without a reboot. If you're booted from SAN, look carefully at your boot LUN and make sure there's nothing wonky with it, or the zoning for the SAN, or the export of the LUN.

share|improve this answer
add comment

You probably have a stale mtab. Try mounting with the -n option.

share|improve this answer
add comment

Apart from /dev/sda1, if there is any separate partition available, say /boot, then create a directory under /boot and mount your usb drive there. What I suspect is /mnt is also part of /. If / is ro, then /mnt mount may not work.

share|improve this answer
add comment

Set the mount point to anything that is not on the same partition as "/". For example, often the "/tmp" directory or some other directory is a separate partition. Then, it's as simple as creating a temporary mount point:

mkdir -p /tmp/mnt

and then

# mount -t ext3 /dev/sdb1 /tmp/mnt

AS long as /tmp is on a separate mountable partition, it completely bypasses any issues you're having with the root partition.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.