Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i am facing an issue with my vHost setup which I rly can't figure out how to fix

First my vhost config:

<VirtualHost *:80>
ServerName dnsmaster.anonogle.com:80
DocumentRoot /var/www/dns
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/dns>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:443>
ServerName chat.anonogle.com:443
DocumentRoot /var/www/chat
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/chat>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
SSLEngine on
SSLCertificateFile /etc/apache2/ssl/apache.crt
SSLCertificateKeyFile /etc/apache2/ssl/apache.key
</VirtualHost>

Both vHost are located in the default file (000-default) - Also this is all there is in that file.

The first vHost works fine, and are also working with SSL/HTTPS but when I try to go to second vHost, then it redirects me to the first one.

I've never faced this problem before, and have been setting a few vHosts up in the past.

But never 2 vHost where one is HTTPS and the other is HTTP

also this is the ports.conf: (default)

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
NameVirtualHost *:443
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.