Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running on CentOS 5.3 (a comet chat server, will have lots of tcp connections). Recently I found it was very slow (http service and ssh) so I use "ifconfig" command to figured out what happened.

eth0      Link encap:Ethernet  HWaddr 00:1C:C0:B5:D5:EA  
          inet addr:10.0.0.61  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:c0ff:feb5:d5ea/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:871861 errors:0 dropped:489662344145 overruns:0 frame:0
          TX packets:639044 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:207239658 (197.6 MiB)  TX bytes:169416201 (161.5 MiB)
          Interrupt:225 Base address:0x6000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:44497 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44497 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11470951 (10.9 MiB)  TX bytes:11470951 (10.9 MiB)

When I restart its network, all goes well. But after a period of time it will be slow again.

Can someone help?

Updated:

================================================================================

As Rajat requested, I wlll post some information for diagnosing

 uname -a
Linux im.cluster.myserver.com 2.6.18-128.el5 #1 SMP Wed Jan 21 10:41:14 EST 2009 x86_64 x86_64 x86_64 GNU/Linux


sudo /sbin/lspci | grep Ethernet
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

 sudo dmesg | grep eth0
eth0: RTL8168d/8111d at 0xffffc20000006000, 00:1c:c0:b5:d5:ea, XID 281000c0 IRQ 225
r8169: eth0: link up
r8169: eth0: link up
eth0: no IPv6 routers present
r8169: eth0: link up
eth0: no IPv6 routers present



 sudo /sbin/ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: p
        Current message level: 0x00000033 (51)
        Link detected: yes



sudo /sbin/ethtool -k eth0
Offload parameters for eth0:
Cannot get device udp large send offload settings: Operation not supported
rx-checksumming: on
tx-checksumming: off
scatter-gather: off
tcp segmentation offload: off
udp fragmentation offload: off
generic segmentation offload: off


 sudo /sbin/ethtool -S eth0
NIC statistics:
     tx_packets: 4483119
     rx_packets: 7443820
     tx_errors: 0
     rx_errors: 0
     rx_missed: 0
     align_errors: 0
     tx_single_collisions: 0
     tx_multi_collisions: 0
     unicast: 3591906
     broadcast: 442720
     multicast: 3851914
     tx_aborted: 0
     tx_underrun: 0
share|improve this question
    
how does link status look on the switch side? <mallicious_mode>RTL8168d - you see. there is your problem. realtek...</mallicious_mode> –  pQd Aug 18 '09 at 8:36

2 Answers 2

up vote 6 down vote accepted

couple of things to check:

  • run ethtool eth0 and see what speed/duplex status you have on the interface, then check if switch on the port you connect your server to has the same settins [ expected are: full duplex, 100 or 1000 MBit/s. identical on both sides ]

  • if there is no duplex missmatch - check the switch port and the network interface - maybe one of them is faulty

  • check / replace the patch-cord, maybe it is faulty or goes along some source of interference

share|improve this answer

which network card are you using it is normally do with driver u can re install them

uname -a
lspci |grep Ethernet
dmesg |grep eth0
ethtool eth0
ethtool -k eth0
ethtool -S eth0

take the out put of this and post back

share|improve this answer
    
the question was what causes the problem, not how to cease it without fixing –  asdmin Aug 16 '09 at 8:50
    
@Rajat, I will post the information you need soon –  Mickey Shine Aug 18 '09 at 8:22
    
Sorry, seems can not post formatted text as commet. I will update my question soon –  Mickey Shine Aug 18 '09 at 8:24
1  
no pro i m also using same r8169 what i did come out of this i use r8101 driver from realtek so i suggest re-install the driver and try it should work –  Rajat Aug 20 '09 at 13:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.