Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to PXE-boot desktop-machines to install a new OS over the network, but it isn't picking up an IP address via DHCP during boot. When an OS is already booted on the machine, it is working fine. In the past i had some issues with this, because of misconfigured RSTP. But with spanning-tree [PORT] admin-edge-port on HP-Switches (equivalent to ciscos portfast i guess) i thought i solved this. Now it is back, with exactly the same symptoms... PXE-Boot:

Client -> Server: DHCP-Discover
Server -> Client: DHCP-Offer
Client -> Server: DHCP-Discover
Server -> Client: DHCP-Offer
.... looping...

I tried several things:

  • extending the boot time (memory check on the client)
  • disabling RSTP
  • disable auto-negotiate between Switch and Client

I am at my wit's end. Someone has an idea?

share|improve this question
    
What kind of PXE server are you using? The DHCP-Offer probably means it is getting an IP, but it's not going to boot if it doesn't also receive a boot filename. Have you tried capturing packets at the DHCP server and/or PXE server? –  1.618 Oct 11 '13 at 17:13
    
DHCP and PXE are on the same machine. I captured the traffic by mirroring the client port and dumping the packets with wireshark. I have only seen the discover and the offer... But yes.. Maybe there is something wrong with the PXE-Server (wrong boot-filename etc.). I will discover it on monday. Thanks so far! –  derhelge Oct 11 '13 at 17:20

1 Answer 1

up vote 1 down vote accepted

If DHCP is working through the operating system, but not through PXE, something is likely amiss with the firmware / configuration of the NIC itself.

Get in to the firmware of the NIC during boot-up (usually there is either a Cntl-Key sequence, or you access the BIOS if it's onboard) and see what sort of options are available for adjusting.

Make sure the interface the OS is DHCP'ing off of is really the same interface that is failing to PXE. With a desktop you might only have a single interface, but if there is more than one there are regular problems where OS device enumeration isn't what you anticipate.

You may also try other desktops (with other NICs) to see if the problem is just a specific firmware version / manufacturer, or perhaps the problem is larger.

share|improve this answer
    
Thanks. It wasn't a deep network problem... Just a combination of a bad firmware and a wrong info from our user-helpdesk. –  derhelge Oct 14 '13 at 13:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.