Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two accounts on a centOS server. The first account has a normal public_html folder, the second account has a symlink to the first account public_html folder instead of a normal one.

The first account domain opens fine, but the second account domain shows a 403 Forbidden error. This seems to be a permissions problem because if I use chown to give the second user ownership or the first user folder then it works fine, but the first user is the one that shows the error in this case.

I had this working fine previously, but the server was hacked and I had to rebuild apache and since then it stopped working.

I tried adding the second user to the first user group in the /etc/group file and also checked the checkbox for "exclude restriction" for open_basedir on whm, but the error still persist.

What can I try to make this work like before?

share|improve this question
Removed SymLinksIfOwnerMatch from httpd.conf and now it seems to be working. –  petergrah Oct 11 '13 at 16:29
You could add the answer as a reply and accept it as a solution. It helps when someone is searching for the correct answer. –  dastergon Oct 11 '13 at 16:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.