Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running CentOS 6 with cPanel and Exim. Spamassassin headers are showing up in email but I can't use spamassassin commands in terminal.

# spamassassin
-bash: spamassassin: command not found
# spamd
-bash: spamd: command not found

I have tried running as root as well.

I have tried restarting exim and spamd, and it successfully shows shutting down of the services.

Should I try to install via yum? I'm afraid to end up with 2 copies of the software.

Thank you for any solutions.

EDIT: Alos, sa-learn commands returning not found

share|improve this question

2 Answers 2

up vote 1 down vote accepted

They're probably just not in your $PATH environment variable. Find them with

find / -name spamassassin

then invoke using the full path and/or add the folder to $PATH.

share|improve this answer

As root, execute the cpanel script that will identify the spamassassin path for you.

/usr/local/cpanel/bin/get_spamassassin_bin_location

Running CentOS 6.5 my executable is located here:

/usr/local/cpanel/3rdparty/perl/514/bin/spamassassin

You can also get a lot of good information about where spamassassin "stuff" lives by running

locate spamassassin
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.