Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

A fresh install of Ubuntu Server is refusing to boot and hanging on "Adding 524284k swap on /dev/mapper/test--vg-swap_1. Priority:-1 extents:1 across:524284k

I can get around this by dropping onto recovery mode and just resuming to a normal boot.

share|improve this question

2 Answers 2

It is doing this because Ubuntu is trying to switch to a high resolution video mode for the console and your hardware isn't cooperating.

When Grub2 shows up:

  • Highlight the menu item for Ubuntu and press 'e'
  • Go to the line where it loads the kernel and press 'End' to go to the end of the line
  • Add 'nomodeset'
  • Press F10 or Ctrl-X to boot it

With any luck it will boot into the login screen. This won't save that option but at least now you can edit the file for Grub2 and update it to save that option if it works. I blogged about this recently.

share|improve this answer
    
Thank you! For others, the line you add nomodeset to is the line that starts with linux /boot/vmlinuz..., not the initrd line. –  Brian Hempel yesterday

How did you add it? You may want to format the swap again. What you can do is boot under rescue mode, mount the vgs and do:

# mkswap /dev/mapper/test--vg-swap_1

# swapon /dev/mapper/test--vg-swap_1

Then add it again to the /etc/fstab if it's not present.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.