Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OK, before you get all "OFF TO SUPERUSER WITH YOUR ISSUE!", they specifically state in their Help pages: "NOT about issues specific to corporate IT support and networks", and since this is a corporate network I'm dealing with and I'm the IT manager/sr.admin, well there you go...and yes I feel silly being unable to figure this out myself, but like TLC I ain't too proud to beg. Disclaimer done.


ISSUE

I've been getting this message lately "could not reconnect all network drives" upon a reboot of my Win 8 Pro laptop (example image below):

enter image description here

TROUBLESHOOTING

Yet, when I check both the Explorer GUI (clicking the "click here to check the status of your network drives") and the cmd line "net use" commands, the proper drive mappings are there.

I've also checked the registry under HKEY\CURRENT USER\Network and find the correct mappings.

I see no events in the application, security, or system event logs to correspond to the "error" message.

It appears to me that nothing is wrong.

NOTE: I do know that the same message will appear when I'm "off the corp network", for instance when I'm booting up my laptop at home. I get that...but this is when I'm hardwired into the network and have network connectivity (proven via one of the servers able to ping my laptop and run mgmt tools on it before I log in).

QUESTIONS

So I guess the real questions are:

  1. Is this error message valid at some point? Maybe it is displaying it a split second prior to the drives getting connected for some reason? Is there a way to troubleshoot it and figure out what it is really squawking about?
  2. Barring #1 even being possible, can I simply suppress the message period? I don't really care about it to be honest, so not seeing it won't cause me any grief.
share|improve this question
    
Is network discovery off? –  Colyn1337 Oct 15 '13 at 13:33
    
@Colyn1337 - on the domain profile no...private profile yes. –  TheCleaner Oct 15 '13 at 13:37
    
Just curious, not that I think it matters, but are the drives mapped with the FQDN or the short name? –  MDMarra Oct 15 '13 at 13:38
    
Are you using non windows dns (such as an IPAM appliance)? –  Colyn1337 Oct 15 '13 at 13:40
3  
OFF TO SUPERUaww. –  tombull89 Oct 15 '13 at 13:43
show 4 more comments

1 Answer 1

up vote 7 down vote accepted

If you don't have Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon configured in your GPO, it's possible that your computer boots and you log in with cached credentials before the NIC is up and has obtained an address. Then, by the time you get around to opening Explorer, you've got an address and your mapped drives are no longer disconnected.

On modern hardware you shouldn't need to configure this, but I've seen some terrible NIC drivers out there so better safe than sorry. Although, this typically fixes GPO processing issues not mapped drives, but it's worth a shot.

share|improve this answer
    
That gpo setting isn't pushed out currently, like you said I haven't seen a need to configure this on our network yet. I will set my local policy setting for this and let it run a few days and see what happens. –  TheCleaner Oct 15 '13 at 13:45
    
Well, that solved it...at least for me on Windows 8 Pro. I am upgrading now to 8.1 and will turn off this local setting and see if it happens again, but so far this has definitely fixed the issue. Thanks man. –  TheCleaner Oct 17 '13 at 13:47
    
nailed it –  MDMarra Oct 17 '13 at 15:09
    
Actually, funny thing is that on the first boot of 8.1 it was back. But subsequent reboots it is fine. Could be that the initializing of 8.1 held back the GP processing on first run but who knows. –  TheCleaner Oct 17 '13 at 15:24
    
GPO may not have applied on the first boot, entirely possible. –  MDMarra Oct 17 '13 at 15:24
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.