Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to access my IIS test site by the server IP. Internally I have no problems, but externally it tries for a while and then times out.

I've run shields up and it shows that their are no open ports. It's a 1&1 VPS server running Windows Server 2003 so I assume there would be no firewall blocking in the middle. I've read somewhere that I may have to make changes in Administrative Tools > Local Admin Settings to allow access to port 80, but I don't know where to begin looking in here.

Edit:

I am accessing the server by its external IP address, the same I use to log into RDP. 1&1 also provide all VPSs with a subdomain which resolves to the server, which again is fine for RDP but fails with IIS over port 80. Using both the IP and subdomain on the server itself return the site successfully.

share|improve this question
    
Rob, sorry to ask the obvious but just to get it out of the way, are you using an internal address to access the server, such as 10.x.x.x, 172.16.x.x, 192.168.x.x ? In other words, is the address of the IIS server in one of those ranges? If so, please clarify what you mean by internally and externally. –  Beel Aug 15 '09 at 19:39
add comment

8 Answers

up vote 4 down vote accepted
+100

Have you checked is Windows Firewall is on? If it is, you should either disable it or (better) allow incoming traffic to port 80.

Also, are you behind some NAT? You can check it quite easily: run IPCONFIG on the server and have a look at its IP address; if it's different from the external one, then there's some NAT in te middle, and you need your provider to properly configure it.

Last chance, even if you have no firewall on your server and it's actually sitting on its public IP address, there actually could be some firewall in the middle, so you should check that with your provider, too.

share|improve this answer
1  
Thank you very mouch for the bounty, but now I'm curious as to what the issue was :-) –  Massimo Aug 20 '09 at 16:27
add comment

Your access your web site via a subdomain, like aaa.stackoverflow.com/Default.aspx or direcly via ip adresse like x.x.x.x/Default.aspx ?

If you access via a sub domain, your binding is it correct. Did your URL in IIS is set to the correct IP adresse or is set to All IP Adreses ?

Your external IP adress is it NAT to an internal ip adresse ?

Can you make a telnet on port 80 from the external ?

share|improve this answer
add comment

Try with opening IIS management console, right click on the web site, properties, click on the "Directory Security" tab, then pick Edit button for "IP address and domain name restrictions".

BTW, you can check if IIS is listening on the external address with netstat -a -p tcp -n within command prompt on the server in question.

share|improve this answer
add comment

The first basic test is to use telnet.exe to connect to the port:

        telnet <ip address> 80

If you get a 'Connection refused' error then the port is not open.

Also WS 2003 has a firewall: type firewall.cpl and you should see the local control panel.

share|improve this answer
add comment

Aside from the other answers, check your network interface bindings to make sure that IIS is bound to your external interface.

  1. You can do this by going to the website properties, click the Website tab, and then making sure that the IP address text is: (All Unassigned).
  2. Also, make sure that the port is listening on 80 (or 443 for SSL).
  3. Click on the Advanced button. Make sure that the host header value is equal to the domain that you're wanting to reach. For example, if you want your website reachable at http://blog.waynehartman.com, you would have to make sure that blog.waynehartman.com is in the host header.
share|improve this answer
add comment

Have you tried using a different connection on a different Internet connection to connect to the server?

Are you able to access sites such as www.serverfault.com from the computer that you're trying to use to access the server from?

share|improve this answer
add comment

It is possible that what fails is the authentication. Try to set your test site to allow anonymous access and see if that helps. Use the free Fiddler tool to double check and see what is really going on.

share|improve this answer
add comment

I have a 1&1 VPS as well, and what I did was run the Security Configuration Wizard

http://www.microsoft.com/windowsserver2003/technologies/security/configwiz/default.mspx

After going through all of this, and setting everything up how I wanted, I was able to have complete control over everything on the server.

I'm sure there is a more complicated way of doing this, but I was impressed with this tools ease of use.

share|improve this answer
    
+1 Very good suggestion, the secwizard is an awesome base for hardening a windows server... and in this case it most likely will help you open up port 80 as well - by detecting IIS. –  Oskar Duveborn Aug 20 '09 at 15:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.