Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get a Galera cluster running. I have the first node up and ready for connections. My second node, however, when trying to run wsrep_sst_xtrabackup gets the error "Can't find innobackupex in the path". As soon as I start the mysql service on the second node, I briefly see it as an incoming address on the first node, but then it goes away.

Not sure what would be necessary to help me with this, so here's my whole wsrep specific section of my my.cnf from the second node that is giving me problems:

binlog_format=ROW                                                                                     
default_storage_engine=innodb                                                                         
innodb_autoinc_lock_mode=2                                                                            
innodb_locks_unsafe_for_binlog=1                                                                      
innodb_doublewrite=1                                                                                  
wsrep_provider=/usr/lib/galera/libgalera_smm.so                                                       
wsrep_provider_options="gcache.size=256M; gcache.page_size=128M"
wsrep_cluster_address=gcomm://firstnode                                                          
wsrep_cluster_name="Cluster"
wsrep_node_address="thisnode"
wsrep_node_name="thisnode"
wsrep_sst_method=xtrabackup                                                                           
wsrep_sst_auth="root:password"
wsrep_node_incoming_address=this node's IP
wsrep_sst_receive_address=this node's IP                                                             
wsrep_slave_threads=16

Am I missing a parameter or something for xtrabackup?

Edit: tried changing the "firstnode" name to an actual IP address. Did not help.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The answer is unimpressive and silly. Make sure you have xtrabackup installed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.