Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am starting from scratch to launch a new Elastic Beanstalk environment using 64-Bit Amazon Lunix AMI version 2013.09. It is for tomcat 7 non-legacy container.

But after the environment is created and the instance has been launched, the URL (where the deployed app is supposed to be available) is not working.

I checked the instance itself & it seems that tomcat is not installed on it, let alone starting it. So I checked out the log file at /var/log/cfn-init.log and I saw some issues in it which might be causing this.

Error: Package: perl-ExtUtils-MakeMaker-6.55-127.15.amzn1.x86_64 (amzn-main)
           Requires: perl = 4:5.10.1-127.15.amzn1
           Installed: 4:perl-5.10.1-131.19.amzn1.x86_64 (installed)
               perl = 4:5.10.1-131.19.amzn1
           Available: 4:perl-5.10.1-127.15.amzn1.x86_64 (amzn-main)
               perl = 4:5.10.1-127.15.amzn1
Error: Package: perl-CGI-3.51-127.15.amzn1.x86_64 (amzn-main)
           Requires: perl = 4:5.10.1-127.15.amzn1
           Installed: 4:perl-5.10.1-131.19.amzn1.x86_64 (installed)
               perl = 4:5.10.1-131.19.amzn1
           Available: 4:perl-5.10.1-127.15.amzn1.x86_64 (amzn-main)
               perl = 4:5.10.1-127.15.amzn1
Error: Package: 4:perl-devel-5.10.1-127.15.amzn1.x86_64 (amzn-main)
           Requires: perl = 4:5.10.1-127.15.amzn1
           Installed: 4:perl-5.10.1-131.19.amzn1.x86_64 (installed)
               perl = 4:5.10.1-131.19.amzn1
           Available: 4:perl-5.10.1-127.15.amzn1.x86_64 (amzn-main)
               perl = 4:5.10.1-127.15.amzn1
Error: Package: perl-Test-Simple-0.92-127.15.amzn1.x86_64 (amzn-main)
           Requires: perl = 4:5.10.1-127.15.amzn1
           Installed: 4:perl-5.10.1-131.19.amzn1.x86_64 (installed)
               perl = 4:5.10.1-131.19.amzn1
           Available: 4:perl-5.10.1-127.15.amzn1.x86_64 (amzn-main)
               perl = 4:5.10.1-127.15.amzn1
Error: Package: 1:perl-ExtUtils-ParseXS-2.2003.0-127.15.amzn1.x86_64 (amzn-main)
           Requires: perl = 4:5.10.1-127.15.amzn1
           Installed: 4:perl-5.10.1-131.19.amzn1.x86_64 (installed)
               perl = 4:5.10.1-131.19.amzn1
           Available: 4:perl-5.10.1-127.15.amzn1.x86_64 (amzn-main)
               perl = 4:5.10.1-127.15.amzn1
Error: Package: perl-Test-Harness-3.17-127.15.amzn1.x86_64 (amzn-main)
           Requires: perl = 4:5.10.1-127.15.amzn1
           Installed: 4:perl-5.10.1-131.19.amzn1.x86_64 (installed)
               perl = 4:5.10.1-131.19.amzn1
           Available: 4:perl-5.10.1-127.15.amzn1.x86_64 (amzn-main)
               perl = 4:5.10.1-127.15.amzn1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

2013-10-17 17:43:09,582 [ERROR] Error encountered during build of TomcatContainerInstallPackages: Could not successfully install/update yum packages (return code 1)
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/construction.py", line 511, in run_config
    CloudFormationCarpenter(config, self._auth_config).build(worklog)
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/construction.py", line 216, in build
    changes['packages'][manager] = CloudFormationCarpenter._packageTools[manager]().apply(packages, self._auth_config)
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/rpm_tools.py", line 103, in apply
    raise ToolError("Could not successfully install/update yum packages", result.returncode)
ToolError: Could not successfully install/update yum packages (return code 1)
2013-10-17 17:43:09,584 [ERROR] Unhandled exception during build: Could not successfully install/update yum packages (return code 1)
Traceback (most recent call last):
  File "/opt/aws/bin/cfn-init", line 122, in <module>
    worklog.build(detail.metadata, configSets)
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/construction.py", line 117, in build
    Contractor(metadata).build(configSets, self)
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/construction.py", line 502, in build
    self.run_config(config, worklog)
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/construction.py", line 511, in run_config
    CloudFormationCarpenter(config, self._auth_config).build(worklog)
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/construction.py", line 216, in build
    changes['packages'][manager] = CloudFormationCarpenter._packageTools[manager]().apply(packages, self._auth_config)
  File "/usr/lib/python2.6/site-packages/cfnbootstrap/rpm_tools.py", line 103, in apply
    raise ToolError("Could not successfully install/update yum packages", result.returncode)
ToolError: Could not successfully install/update yum packages (return code 1)`

I dont understand whats up with this, have you faced these issues? If so how did you manage to resolve it.

I can also attach the complete log cfn-init.log if that helps.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.