Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had setup a multinode cluster using CentOS with VMware yesterday. Today when I reboot the nodes I get the below error on startup.

"there is a problem with the configuration server status 256 centOS" (/usr/libexec/gconf-sanity-check-2 )

I am unable to login as root or any user as the screen is frozen.

The solutions online is to change the permissions for some tmp files.

My problem is I am unable to access the terminal as I cannot login. Also on reboot I do not have any recovery options in CentOS. I only see command line GRUB.

I am new to linux and Hadoop.Pls help asap.

share|improve this question
You can edit the kernel line in grub by pressing e and add a 1 or single as parameter to the end of the kernel line and boot it. – val0x00ff Oct 18 '13 at 9:11

You'll need to access the filesystem so that you can make the permissions changes on the tmp files. There are a couple different ways you can do this. First, powercycle so that you can get to the GRUB prompt.

  1. edit the kernel line and add single at the end, then boot. This puts you in single user mode as the root user. Then you can make changes to those files.

  2. If the above doesn't work, you can go back to the GRUB prompt, edit the kernel line, and put "init=/bin/sh" anywhere on the line. Then boot. This will provide you a very quick boot to a very limited shell. From there you will need to mount the filesystem that has the tmp files, and make changes.

If you encounter GRUB errors that prevent either of the above two methods from booting, then you'll need to repair the GRUB boot loader. You can do this by getting into a Grub prompt, figuring out which partition contains the boot files, and running Grub's "setup" command on that partition.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.